Project

General

Profile

Bug #8593

MacOSX: Dartkable master crashes during image import

Added by blender3dartist - about 7 years ago. Updated almost 7 years ago.

Status:
Fixed
Priority:
Medium
Assignee:
-
Category:
General
Target version:
Start date:
Due date:
% Done:

100%

Affected Version:
git development version
System:
bitness:
64-bit
hardware architecture:
amd64/x86

Description

When attempting to import an image (whether jpg or cr2, canon raw) darktable segfaults.
The program opens correctly (sometimes), and the interface buttons work (to a certain extent, as no image is selected or can be selected).
Upon restart, the images are still not loaded, meaning it is impossible to edit images at all.
Can't import from folder either.

History

#1 Updated by integersf - almost 7 years ago

What version do you use and what macos version?

#2 Updated by blender3dartist - almost 7 years ago

Mac OS 10.6.8, Snow Leopard

#3 Updated by James C. McPherson almost 7 years ago

The function that appears to be the last called before the crash is
gomp_resolve_num_threads(). If you run darktable with

-v -t 4

(for verbose and 4 threads), does that help the import?

#4 Updated by blender3dartist - almost 7 years ago

No, it does not.

Actually, I had to revert to a previous version because the current master doesn't build.

#5 Updated by Simon Spannagel over 6 years ago

  • Affected Version set to git development version
  • % Done changed from 0 to 20
  • Status changed from New to Incomplete

currently parafin is working again on the OSX port. I'll notify him and we'll se if this is still valid.

#6 Updated by Igor Kuzmin over 6 years ago

  • % Done changed from 20 to 100
  • Status changed from Incomplete to Fixed

My patches for OS X has been commited to git master. Besides some GUI color issues, DT works for me on Mountain Lion. Also note that gomp_resolve_num_threads function seems to be OpenMP related, and OpenMP is currently forced off for OS X build, system compiler still doesn't support OpenMP and I haven't yet experimented with alternatives.
I'll mark this bug as fixed (mostly because it's quite old), please try current git master and feel free to reopen this bug or report new ones if it still doesn't work for you.

Also available in: Atom PDF