Project

General

Profile

Bug #8582

Fails to upload to picasaweb

Added by daryll - about 8 years ago. Updated almost 7 years ago.

Status:
Fixed
Priority:
Low
Category:
General
Start date:
Due date:
% Done:

100%

Estimated time:
Affected Version:
1.0
System:
unknown
bitness:
64-bit
hardware architecture:
amd64/x86

Description

This is my first time using DarkTable, but I'm liking the feature set.I'm running 0.9.3 on Fedora 15.

Once I finished editing I went to the light table and opened the
"export selected" panel.
I selected "picasa webalbum" as my target storage.
I filled in my username and password.
At this point a green line showed up saying my credentials were accepted.
I selected an existing album picasa
I set it up to output a jpeg at 100% with no size limits. The image is 2560x1600.
I then clicked the export button and got back a message saying "Failed to get the parameters from the target storage."

I launched DarkTable from a terminal window and noticed the following message that looked suspicious to me:
Something went wrong.. album index 4 = NULL

History

#1 Updated by Henrik Andersson about 8 years ago

  • Status changed from New to In Progress

Hi Daryll

I can't reproduce, was this a single failure or does
it happen all the time for you ?

If you click the reauthenticate button does it work
after that ?

Do you see any suspicious about the combobox showing
you available albums ?

Did you try create a new album or selected an existing one ?

#2 Updated by daryll - about 8 years ago

Yes it's "fairly" consistent for me. I tried it a few times before I sent the report.

I just tried a few things and seemed to have narrowed things down a bit. If I refresh the album, the first export after that works. If I try to upload a second time it fails with the same error.

The available albums list seems fine.

Here's the terminal output:

tempfile: /home/daryll/.local/tmp/darktable.Q87P5V.jpg
tempfile: /home/daryll/.local/tmp/darktable.0QKV5V.jpg
Something went wrong.. album index 4 = NULL
Error: Directory Samsung2 with 3845 entries considered invalid; not read.
Something went wrong.. album index 4 = NULL
tempfile: /home/daryll/.local/tmp/darktable.MNFJ5V.jpg
Something went wrong.. album index 0 = NULL
Something went wrong.. album index 0 = NULL
Something went wrong.. album index 4 = NULL
tempfile: /home/daryll/.local/tmp/darktable.9UMO5V.jpg
Error: Directory Samsung2 with 3845 entries considered invalid; not read.
Something went wrong.. album index 3 = NULL
Something went wrong.. album index 0 = NULL
tempfile: /home/daryll/.local/tmp/darktable.ABG05V.jpg
Error: Directory Samsung2 with 3845 entries considered invalid; not read.

The failures are different folders.
I don't know where the Samsung2 thing is coming from. I don't have a folder called Samsung2.

Sending it to a new folder seems to work more consistently. I was able to upload multiple files without refreshing the folder list.

That's an odd mix of results. It smells vaguely like memory corruption somewhere, but I hope it makes more sense to you than it does to me. :)

#3 Updated by Jose Carlos Garcia Sogo almost 8 years ago

Nothing has changed in Picasa module lately (AFAIK) but it is still happening? It could be an unrelated problem that was fixed in the meanwhile.

Kind regards

#4 Updated by Jose Carlos Garcia Sogo almost 8 years ago

No, it has not been fixed, I can reproduce it now. Upload an image to Picasa, try to upload another one, and it will fail with the album index problem.

#5 Updated by Simon Spannagel over 7 years ago

  • Target version changed from 1.0.3 to Candidate for next patch release

#6 Updated by Jose Carlos Garcia Sogo almost 7 years ago

  • System set to unknown
  • Affected Version set to 1.0
  • % Done changed from 0 to 100
  • Status changed from In Progress to Fixed

Fixed in the upcoming release 1.2

Also available in: Atom PDF

Go to top