Project

General

Profile

Bug #8560

Vignetting is applied to late in the processing pipe -> Crop & Rotate breaks vignetting

Added by Markus Jung over 8 years ago. Updated almost 8 years ago.

Status:
Closed: invalid
Priority:
Low
Assignee:
-
Category:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Affected Version:
git development version
System:
bitness:
64-bit
hardware architecture:
amd64/x86

Description

darktable --version

this is darktable 0.9.2

(from Ubuntu PPA, running Ubuntu Maverick)

Rotating an image breaks an applied vignetting-filter.
Vignetting should be applied before any picture geometry changes or update it's parameters accordingly.

Steps to reproduce:
1. Apply vignetting next to one of the corners of an image.
2. Use crop & rotate to rotate the image for 180°

Expected: The vignette rotates with the image and is is next to the corner opposite to its positon before the image has been rotated.
What happens: The vignette stays where it was before, thus vignetting now another part of the image than before.

By the way, the vignetting-filter should imho allow larger sizes of the generated vignette, to allow vignettes look like a sector of a circle.

History

#1 Updated by Simon Spannagel almost 8 years ago

Confirmed with 1.0rc2.

Think this is by design though.

#2 Updated by Simon Spannagel over 7 years ago

  • Target version changed from 1.0.3 to Candidate for next patch release

#3 Updated by Simon Spannagel over 7 years ago

  • Affected Version set to git development version
  • % Done changed from 0 to 20
  • Target version changed from Candidate for next patch release to Candidate for next minor release
  • Status changed from New to Triaged
  • Subject changed from [0.9.2] Vignetting is applied to late in the processing pipe -> Crop & Rotate breaks vignetting to Vignetting is applied to late in the processing pipe -> Crop & Rotate breaks vignetting

pipe unchanged.

#4 Updated by Tobias Ellinghaus over 7 years ago

  • % Done changed from 20 to 0
  • Status changed from Triaged to Closed: invalid

This is working as intended. Vignetting is an artistic module, not meant for lens correction.

#5 Updated by Markus Jung over 7 years ago

Tobias Ellinghaus wrote:

This is working as intended. Vignetting is an artistic module, not meant for lens correction.

IMHO this is independent of the use of vignetting. If a vignette gets applied on an image, it should move with the the image if it gets rotated afterwards. This is true in both cases, artistic use and correctional use. Simple example: A vignette used to accentuate the face of a person. Later you choose to rotate the image a bit and apply some stronger cropping and volià, the vignette is somewhere else, but not on the face any more.

This behaviour is broken.

#6 Updated by Pascal de Bruijn over 7 years ago

Vignette needs to be late in the pipe, as the default parameters will center it on the image. Applying crop after Vignette would very often end in an asymmetric vignette, which is much worse than the behavior described above.

So this really works as intended but currently assumes you do a proper crop before make other adjustments.

#7 Updated by Markus Jung over 7 years ago

Pascal de Bruijn wrote:

Vignette needs to be late in the pipe, as the default parameters will center it on the image. Applying crop after Vignette would very often end in an asymmetric vignette, which is much worse than the behavior described above.

Well, a quite difficult situation. But: Like i have been told more than once: Vignetting is not intended for lens correction. And for use cases other than lens correction, the placement of the vignette will depend on the image.

I think there is no easy solution since there are good arguments for both usages, maybe vignetting should have options which allow locking its position with respect to crop&rotate. Maybe this "bug" should be converted into a feature request?!

Also available in: Atom PDF

Go to top