Project

General

Profile

Bug #8553

Images exported with sRGB profile are black when viewed in windows viewer

Added by Jose Carlos Garcia Sogo about 7 years ago. Updated over 6 years ago.

Status:
Closed: upstream
Priority:
High
Assignee:
-
Category:
General
Start date:
Due date:
% Done:

0%

Affected Version:
git development version
System:
bitness:
64-bit
hardware architecture:
amd64/x86

Description

All JPGs exported with color profile sRGB (darktable profile) are displayed completely black in windows viewer (confirmed in XP and Windows 7). Any other viewer display them correctly (or at least they ignore the profile).

The quality or size of the exported JPG doesn't matter regarding this issue.

Associated revisions

Revision 36c22d96
Added by Tobias Ellinghaus about 6 years ago

Create sRGB profiles that work under Windows

See bug #8553.
TODO: add copyright blurb to srgb_tone_curve_values.h.

History

#1 Updated by James C. McPherson almost 7 years ago

I had a go at exporting a bunch of images with different intents and colourspaces
to see if there was anything consistent about them with the failure to view them
in Windows7 Viewer.

intent            colourspace      work/notwork?
----------------  -------------    ----
imagesettings     imagesettings    mostly worked (9/10 images)
imagesettings     [[AdobeRGB]]         mostly worked (7/10 images)
saturation        [[AdobeRGB]]         works

abs colorimetric  sRGB             fail
rel colorimetric  sRGB             fail
imagesettings     sRGB             fail
saturation        sRGB             fail

#2 Updated by James C. McPherson over 6 years ago

As a workaround to this problem, I suggest installing IrfanView and its plugins from http://www.irfanview.com.

#4 Updated by James C. McPherson over 6 years ago

One other thing I've noticed - if I view troublesome images in fullscreen mode with Windows Picture and Photo Viewer, then the app has no problems displaying them no matter which intent or colour space setting was chosen.

#5 Updated by Pascal de Bruijn over 6 years ago

I'm not sure we can really fix this. Your last observation really does suggest it's Winows Picture and Photo Viewers fault.

The only thing we could do is offer an option to not embed a color profile at all (working around the issue at hand). Something like "sRGB (don't embed)".

#6 Updated by Simon Spannagel over 6 years ago

  • Target version changed from 1.0.3 to Candidate for next patch release

#7 Updated by James C. McPherson over 6 years ago

  • Affected Version set to 0.9.3
  • Status changed from New to Closed: upstream

This is a bug in the Windows Photo/Fax/Picture view application, with numerous complaints about it [with images from several different applications being victims] found via google. There is no fix for the problem from Microsoft - their suggestion is to update your display's color management profile and try again [although this doesn't seem to work in at least 50% of the cases I reviewed].

The best approach to working around this problem is to install IrfanView.

#8 Updated by Ivan Tarozzi over 6 years ago

James C. McPherson wrote:

This is a bug in the Windows Photo/Fax/Picture view application, with numerous complaints about it [with images from several different applications being victims] found via google. There is no fix for the problem from Microsoft - their suggestion is to update your display's color management profile and try again [although this doesn't seem to work in at least 50% of the cases I reviewed].

Have you some link (best would be MS support link) where this is described?
Simply to explain who receive my images the issue is not DT related ;)

The best approach to working around this problem is to install IrfanView.

Or strip color profile using exiv2 or exiftool, as Markus wrote in ML:
exiftool -ICC_Profile= -overwrite_original "$IMAGE"

#9 Updated by Pascal de Bruijn about 6 years ago

  • Affected Version changed from 0.9.3 to git development version

Another workaround for the short term might be using an ICCv2 version of sRGB (we embed a v4 version, as per LCMS2).

http://files.pcode.nl/icc/srgb.icc

Download that, and put it into ~/.config/darktable/color/out

And select it during export.

Also available in: Atom PDF