Project

General

Profile

Bug #8535

XMP sidecar ignored if named incorrectly.

Added by hfiguiere - over 8 years ago. Updated over 7 years ago.

Status:
Closed: invalid
Priority:
Low
Assignee:
-
Category:
General
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Affected Version:
git development version
System:
bitness:
64-bit
hardware architecture:
amd64/x86

Description

I imported files into Darktable and Darktable ignored them

img_8211.jpg came with img_8211.xmp


Related issues

Related to darktable - Bug #8403: XMP sidecar: xpacket/xml format, filename, overwritingDuplicate

History

#1 Updated by Tobias Ellinghaus over 8 years ago

See you ticket #8533. You can rename the .xmp files to have them read.

I'm leaving this one open. Maybe someone would like to add reading of these xmp files? However, keep in mind, that then there are two sidecar files which will diverge over time. Not good.

#2 Updated by hfiguiere - over 8 years ago

Maybe that's another justification for actually fixing #8533. The goal of sidecars and XMP is to be interoperable.

#3 Updated by hfiguiere - over 8 years ago

XMP Specification part 3, section 1:

"For applications that need to find external XMP files, look in the same directory for a file with the same name as the main document but with an .xmp extension. (This is called a sidecar XMP file.)"

#4 Updated by James C. McPherson over 7 years ago

I'm pretty sure this can be closed - the filename that Darktable looks for is

(filename).(extension).xmp

eg

20120310_135601_IMG_8999.CR2.xmp

filename is 20120310_135601_IMG_8999
extension is CR2

#5 Updated by Simon Spannagel over 7 years ago

  • Status changed from New to Fixed

#6 Updated by hfiguiere - over 7 years ago

Replying to [comment:4 mcbofh]:

I'm pretty sure this can be closed - the filename that Darktable looks for is

(filename).(extension).xmp

eg

20120310_135601_IMG_8999.CR2.xmp

filename is 20120310_135601_IMG_8999
extension is CR2

I'm pretty sure that this is what the bug is about. It is just wrong.

the XMP sidecar is NOT (filename).(extension).xmp but rather (filename).xmp. The XMP spefication is pretty clear.

Darktable is the one doing it wrong and that's what the original bug is about. By not supporting what all the other XMP producers are doing you are just ignoring everything else.

#7 Updated by juanmah - over 7 years ago

XMP purpose is to make metadata accessible to other software and hardware.

Darktable has an odd behaviour managing XMP sidecar files and brakes this accessibility.

#8 Updated by Simon Spannagel over 7 years ago

Freely quoting dinamic:

"It's all about safety, we do not write to source images, nor into others XMP files and we dont want other apps to write into ours. We are not using XMP as an data shuffling synchronization protocol between applications which it is not designed for."

Other applications don't support our name space either way so there's no point in providing them a file they can't use in a sensible way.

We might add import support for other XMP files and other application's tags at some point.

#9 Updated by juanmah - over 7 years ago

"It's not a bug, it's a feature!"

Then, instead of Extensible Metadata Platform, maybe you should use Metadata Platform, or other extension, just to avoid to mean what is not. The standard is designed to be extensible, allowing users to add their own custom types of metadata into the XMP data.

Modifying XMP files is like modifying exif data in an jpg.

#10 Updated by Simon Spannagel over 7 years ago

  • Affected Version set to git development version
  • Status changed from Fixed to Closed: invalid

Also available in: Atom PDF

Go to top