Project

General

Profile

Bug #8483

Error in GPSInfo directory

Added by krisse - almost 9 years ago. Updated over 6 years ago.

Status:
Closed: invalid
Priority:
Low
Assignee:
-
Category:
General
Start date:
Due date:
% Done:

0%

Estimated time:
Affected Version:
git development version
System:
Ubuntu
bitness:
64-bit
hardware architecture:
amd64/x86

Description

Errors reported in GPSInfo directory in JPEG:s created by Darktable (0.8).

Result when running on original RAW/NEF image:

$ exiv2 -M"add Iptc.Application2.Credit String Test" test1.NEF

Result when running on JPEG generated by Darktable:

$ exiv2 -M"add Iptc.Application2.Credit String Test" test1.jpg
Error: Directory GPSInfo: IFD entry 0 lies outside of the data buffer.
Error: Directory GPSInfo: IFD entry 0 lies outside of the data buffer.

The same errors are also reported by exiftool.

Warning: Deleted bad GPS directory - test1.jpg
Error: Truncated GPS directory - test1.jpg

Interesting(?) sidenote: having commandline exiv2 (0.19) process the image leads to metadata having been cleaned up. Ie. if I run the exiv2 command above twice, the second time around no errors are reported.

Same errors not reported by JPEG:s generated from same RAW/NEF by, for example, GIMP (ufraw) or Digikam.

History

#1 Updated by krisse - almost 9 years ago

Couldn't attach RAW/NEF due to filesize restrictions, but you can get it from here:
[http://bit.ly/h4m3FS]

Picture taken by, and thus in-file metadata generated by, a Nikon D90.

#2 Updated by Simon Spannagel almost 8 years ago

Tested. Still valid for 1.0

#3 Updated by Pascal de Bruijn almost 8 years ago

This seems reproducible with darktable-1.0.x and Exiv2 0.22

#4 Updated by Simon Spannagel over 7 years ago

  • Target version changed from 1.0.3 to Candidate for next patch release

#5 Updated by Tobias Ellinghaus over 7 years ago

  • Affected Version set to git development version
  • % Done changed from 0 to 20
  • Status changed from New to Incomplete

Still reproducible?

#6 Updated by Simon Spannagel over 6 years ago

  • System set to Ubuntu

Not reproducible for me using darktable-1.2 and exiv2 0.23

#7 Updated by Simon Spannagel over 6 years ago

  • % Done changed from 20 to 0
  • Status changed from Incomplete to Closed: invalid

Also available in: Atom PDF

Go to top