Project

General

Profile

Bug #8472

DNGs develop to plain white images

Added by André Reinald almost 8 years ago. Updated almost 8 years ago.

Status:
Fixed
Priority:
Medium
Assignee:
-
Category:
-
Target version:
Start date:
Due date:
% Done:

100%

Affected Version:
System:
bitness:
64-bit
hardware architecture:
amd64/x86

Description

I'm using last version from git, stared a new build, then I tried to remove both
.cache/darktable
.config/darktable

then reimported new images, but the problem remains.

I put an image here so you can check by yourself :
http://bolet.no-ip.com/~andre/20110303_145555_suresnes.dng

Maybe I missed something ? But up to now DT has worked fine for me. Now I can't use it at all.

History

#1 Updated by Tobias Ellinghaus almost 8 years ago

Confirmed.

#2 Updated by Henrik Andersson almost 8 years ago

  • Status changed from New to Fixed

#3 Updated by André Reinald almost 8 years ago

  • Status changed from Fixed to Incomplete

I wasn't checking the ticket status, but I was compiling from git daily and didn't notice a change on this issue : it still doesn't work for me.

Note : maybe it's fixed in the OpenCL code, but I run "classic" code.

#4 Updated by André Reinald almost 8 years ago

  • Status changed from Incomplete to Fixed

I just checked out the last sources tonight, and for me at least, the issue seems fixed. It's surprising though because the sources modified during my last pull didn't look related to the issue. Anyway I changed the status to "fixed".

#5 Updated by Henrik Andersson almost 8 years ago

I guess commit d440b2a1d065271174971a508ed4607241990056 solved this issue too,
forcing unsupported cameras in rawspeed to fall thru to libraw fallback.

/Henrik

#6 Updated by André Reinald almost 8 years ago

  • Status changed from Fixed to Incomplete

Sorry to reopen the ticket, but the bug is back again tonight - DNG, no openCL.

#7 Updated by oguth - almost 8 years ago

I get the same bug with DNG files from a Pentax K7. None of the files are displayed, the preview is plain white. Other raw software can open the files with no problem. Darktable also works well with a PEF file from the same camera.
It works well in 0.8.

darktable 0.8+394~g1d0aff3, Arch Linux.

#8 Updated by André Reinald almost 8 years ago

It's ironic that PEF and other proprietary formats work better than DNG in an open source program. Still I'll stick with DNG because it's an open format. DNG is a reason why I picked Pentax in the first place.

#9 Updated by André Reinald almost 8 years ago

  • Status changed from Incomplete to Fixed

The problem with DNGs seems fixed for the last few days. Though none closed this ticket yet, so I guess the fix was more a side effect of some other change.

Also available in: Atom PDF