Project

General

Profile

Bug #8412

Color inconsistencies in file export

Added by Ulrich Pegelow over 8 years ago. Updated over 8 years ago.

Status:
Fixed
Priority:
High
Assignee:
-
Category:
General
Target version:
Start date:
Due date:
% Done:

100%

Affected Version:
System:
bitness:
64-bit
hardware architecture:
amd64/x86

Description

I encountered an issue with file export and correctness of colors. To reproduce it, take a photo with quite saturated colors which has been processed in a previous session with DT.

1) open DT and export photo from lighttable mode into JPEG with internal Adobe RGB and perceptual output intent

2) enter darkroom mode with this photo and immediately go back to lighttable mode again (no changes done)

3) export photo with same parameters as in 1)

Photo exported unter 1 is dull and undersaturated; Photo exported under 3 is good.

I have not tested other profiles but this issue seems to be independent of output file format (tested 8bit/16bit tiff and jpeg)

History

#1 Updated by Tobias Ellinghaus over 8 years ago

Probably related: When I start dt all the thumbnails in lt are dull, after entering and leaving dr the opened images has the correct thumbnail.

@upegelow: How did you manage to export images with AdobeRGB profiles? What version of lcms2 are you using?

#2 Updated by Tobias Ellinghaus over 8 years ago

This is supposed to be fixed (works for me now). Could you please check again?

#3 Updated by Ulrich Pegelow over 8 years ago

@houz:

Unfortunately the latest commit does not improve things. Still exports remain dull, unless I have gone into darkroom mode once.

BTW: this behavior seems to be independent of the profile. I checked with DT's internal Adobe RGB and also with an external Adobe RGB (1998) ICC file.

Further info: I am compiling against lcms2 version 2.1

#4 Updated by Johannes Hanika over 8 years ago

i just found another instance of the old jpeg-thumbnail loading code, in the input color profile code though. but linear rgb instead of enhanced dt matrices could just as well cause your dull images, so please try again.

#5 Updated by Ulrich Pegelow over 8 years ago

I will try this evening, need to repair my computer first (HD problem).

BTW: the issue is not limited to JPEG output. In fact I first observed the problem when I generated 16bit TIFF files.

#6 Updated by Ulrich Pegelow over 8 years ago

I just checked the recent commit. Problem is solved.

Thanks a lot!

#7 Updated by Johannes Hanika over 8 years ago

  • Status changed from New to Fixed

Also available in: Atom PDF