Project

General

Profile

Bug #8303

WB global preset (spot, camera, sunday) box becomes empty when re-opening an already modified image

Added by oliviertoulouse - over 8 years ago. Updated over 4 years ago.

Status:
Fixed
Priority:
Low
Assignee:
Category:
General
Start date:
Due date:
% Done:

100%

Affected Version:
git development version
System:
all
bitness:
64-bit
hardware architecture:
amd64/x86

Description

1) open a new image in darkroom
2) change the white balance to "spot"
3) go back to lighttable
4) return to darkroom
In the white balance module, the list "camera, spot, sunday, ..." becomes unreadable / empty.
You need to select an entry for it to become written in white on a black background thus readable.


Related issues

Duplicated by darktable - Feature #9184: Remember white balance preset name Duplicate 01/17/2013

Associated revisions

Revision c1fc136e
Added by Roman Lebedev over 4 years ago

Temperature IOP: Match stored WB multipliers against all camera WB presets and select matched preset. Fixes #8303

Revision 45b33f56
Added by Roman Lebedev over 4 years ago

Temperature IOP: Match stored WB multipliers against interpolated camera WB presets and select matched preset. Refs #8303

Revision c5f12fba
Added by Roman Lebedev about 4 years ago

Temperature IOP: WB presets: add bound checking. Fixes #10313, Refs #8303

History

#1 Updated by Tobias Ellinghaus over 8 years ago

Confirmed.

#2 Updated by Johannes Hanika over 8 years ago

if you change the wb, the combo box becomes empty, because you deviated from the default (i.e. no entry is selected, the list is still there and legible in the drop down menu). we don't search through all possible presets to see which one matches your settings (only the three coeffs are stored).

i don't mind, but it would probably be an enhancement if we did.

#3 Updated by Simon Spannagel about 7 years ago

This bug still exists in current git master.

Even worse: when switching to another plugin after selecting "spot white balance" and got to lt, return to dr "camera white balance" is selected again.

#4 Updated by Simon Spannagel almost 7 years ago

  • Target version changed from 1.0.3 to Candidate for next patch release

#5 Updated by Johannes Hanika almost 7 years ago

  • % Done changed from 0 to 20
  • Affected Version set to git development version
  • Status changed from New to Triaged

one solution would be:
- in gui_update:
- loop through the settings (3x coeff) for each preset in the combobox
- if the module->params match these, set the gui combobox to that setting, too
- would still result in current behaviour for spot wb

#6 Updated by Simon Spannagel almost 6 years ago

  • System set to all

this still exists in 1.2 and git master
(just to bump)

#7 Updated by Roman Lebedev over 4 years ago

  • Status changed from Triaged to In Progress
  • bitness set to 64-bit
  • % Done changed from 20 to 50
  • Target version changed from Candidate for next patch release to Future
  • Assignee set to Roman Lebedev

#8 Updated by Roman Lebedev over 4 years ago

  • Category set to General
  • Status changed from In Progress to Fixed
  • Target version changed from Future to Candidate for next major release
  • % Done changed from 50 to 100

#9 Updated by Roman Lebedev over 4 years ago

  • Duplicated by Feature #9184: Remember white balance preset name added

Also available in: Atom PDF