Project

General

Profile

Bug #12627

Drawn mask, gradient, "curved" if lens correction applied

Added by Jean-Luc Coulon 2 months ago. Updated 2 months ago.

Status:
Closed: invalid
Priority:
Low
Assignee:
Category:
Masks
Target version:
-
Start date:
03/13/2019
Due date:
% Done:

0%

Affected Version:
git master branch
System:
Debian
bitness:
64-bit
hardware architecture:
amd64/x86

Description

Hi,
I've got a picture with a 14 mm f/2.8 Samyang and an EOS 6D MkII.
I've use the lens correction. Distorsion was corrected.

Further, I want to apply a tonality curve with a drawn mask.
But the limit of the mask is no more a straight line.
It is shaped (curved) the opposite the lens correction is done.
So the shape vary from the top of the picture to the bottom.

See the attached screenshots.

How can I staigthen this limit?

Regards

Jean-Luc

curve-tone-gradient-top.png (883 KB) Jean-Luc Coulon, 03/13/2019 03:45 PM

curve-tone-gradient-bottom.png (738 KB) Jean-Luc Coulon, 03/13/2019 03:46 PM

History

#1 Updated by Pascal Obry 2 months ago

  • Assignee set to Pascal Obry
  • Status changed from New to Closed: invalid

That's not a bug but a feature.

If you have created a mask on a picture for a given area when distorting it (Liquify, perspective correction or lens correction) you want the area to be preserved.

#2 Updated by Jean-Luc Coulon 2 months ago

Okay.. But want to create the mask AFTER applying the lens correction and I would like the gradient mask to have a straight limit. It there a way to do that?

#3 Updated by Mikael Puhakka 2 months ago

Wanted to record here that I also face the same problem with some lenses that have pretty huge distortions.

If you disable the lens corrections, the gradient mask is straight but the horizon is not.

If you enable the corrections, it's the other way around.

Of course there's the workaround where you apply corrections to the raw file first, then export to TIFF or PNG and continue your work on that one. It can be cumbersome, though.

Also available in: Atom PDF