Project

General

Profile

Bug #12561

Darktable cannot import from an SMB network share on Linux

Added by Steve Phelps 3 months ago. Updated 3 months ago.

Status:
New
Priority:
Low
Assignee:
-
Category:
-
Target version:
-
Start date:
01/22/2019
Due date:
% Done:

0%

Affected Version:
2.4.4
System:
Ubuntu
bitness:
64-bit
hardware architecture:
amd64/x86

Description

I'm submitting this as a new issue despite the fact that it is a duplicate of Bug #10790. The latter has been closed but the only solution given was to assign a drive letter to the share, which does not work on Linux. I have an SMB share mounted as `\mnt` but when I try to import folders form it Darktable complains 'Permission denied' when I browse to `\mnt`. All other applications, including the shell, are able to read and write files here with no problems.

sphelps@sphelps-XPS-13-9360:/mnt/Pictures$ ls -lad .
drwxr-xr-x 2 sphelps sphelps 0 Jan 22 09:01 .
sphelps@sphelps-XPS-13-9360:/mnt/Pictures$ mount | grep mnt
//192.168.1.229/media on /mnt type cifs (rw,relatime,vers=default,cache=strict,username=sphelps,domain=,uid=1000,forceuid,gid=1000,forcegid,addr=192.168.1.229,file_mode=0755,dir_mode=0755,soft,nounix,serverino,mapposix,rsize=1048576,wsize=1048576,echo_interval=60,actimeo=1)
sphelps@sphelps-XPS-13-9360:/mnt/Pictures$ touch test
sphelps@sphelps-XPS-13-9360:/mnt/Pictures$ ls -l test
-rwxr-xr-x 1 sphelps sphelps 0 Jan 22 14:04 test
sphelps@sphelps-XPS-13-9360:/mnt/Pictures$ rm test

Screenshot from 2019-01-24 13-38-38.png (272 KB) Steve Phelps, 01/24/2019 03:40 PM

Screenshot at 2019-01-26 08-59-47.png (464 KB) Steve Phelps, 01/26/2019 11:01 AM

History

#1 Updated by Pascal Obry 3 months ago

Since dt does nothing about shares and use OS support there is something wrong with this mount. I'm using a NAS without issue.

What is on you fstab? On my side I have just:

... cifs credentials=/home/obry/.config/cred-mnt,noauto,users,rw

#2 Updated by Steve Phelps 3 months ago

I'm currently using autofs with options as specified in the original post:

//192.168.1.229/media on /mnt type cifs (rw,relatime,vers=default,cache=strict,username=sphelps,domain=,uid=1000,forceuid,gid=1000,forcegid,addr=192.168.1.229,file_mode=0755,dir_mode=0755,soft,nounix,serverino,mapposix,rsize=1048576,wsize=1048576,echo_interval=60,actimeo=1

However, when I mount manually using:

sudo mount -t cifs --options=username=sphelps,password=<redacted>,uid=sphelps,gid=sphelps,rw //192.168.1.229/media /mnt

I still get the same problem.

When you say there is something wrong with the mount, all other applications including Shotwell, file manager and shell can read and write files here, and it is just darktable that has a problem. I've attached a screenshot showing the problem.

The mount-point has following permissions:


sphelps@sphelps-XPS-13-9360:~$ ls -lad /mnt
drwxr-xr-x 2 sphelps sphelps 0 Jan 22 08:33 /mnt

#3 Updated by Steve Phelps 3 months ago

I've solved this issue. I had installed darktable as a snap, and by default snaps do not have permission to access network mounts. After I changed the permissions in the software manager (see attached), I was able to import from the network share.

Also available in: Atom PDF