Project

General

Profile

Feature #12552

Geotagging : wrong map dispaly

Added by Pascal Grataloup about 1 month ago. Updated about 1 month ago.

Status:
Fixed
Priority:
Low
Assignee:
Category:
Map / Geolocation
Target version:
Start date:
01/16/2019
Due date:
% Done:

100%

Affected Version:
git master branch
System:
Windows
bitness:
64-bit
hardware architecture:
amd64/x86

Description

Hi,
the map is not displayed on the coordinates of the currently open image, which is shown in the left panel of the screenshot but is displayed on the last location encoded by drag and drop.
An examination of the xmp files created by dt confirms that the coordinates of the two images appear in the same EXIF fields.
As darktable allows, on import, the recovery of xmp files generated by my LR6, I also did this test. The image has been imported with the xmp coordinates of LR and the xmp generated by darktable also contains them. However, the problem remains: the correct map is not displayed.

bug dt map.jpg - screencopy with the issue (125 KB) Pascal Grataloup, 01/16/2019 10:53 AM

bug dt carte xmp-1.jpg - xmp files of the images on the screencopy (231 KB) Pascal Grataloup, 01/16/2019 10:53 AM

History

#1 Updated by Pascal Obry about 1 month ago

  • Status changed from New to Closed: invalid
  • Assignee set to Pascal Obry
  • Target version deleted (2.6.0)

This is expected, maybe even on the documentation (didn't check). The map is displayed as it was last time it was used. To move the map for a given picture just double click on it in the film strip.

#2 Updated by Pascal Grataloup about 1 month ago

Thank you for this information which does not appear in the documentation.
In any case, having to double click on an already open image is an unnecessary operation. Reading the exifs should be enough to show the correct location.

#3 Updated by Pascal Obry about 1 month ago

  • % Done changed from 0 to 50
  • Status changed from Closed: invalid to In Progress

In any case, having to double click on an already open image

There is no open image in all cases. From the lighttable maybe one selected, but we can have multiple. Should we go to the first selected one? Maybe, makes sense indeed.

#4 Updated by Pascal Grataloup about 1 month ago

The image is open in the darkroom, that's enough to have read the exifs. So from there, the passage in the map module must be able to display the correct location.
It seems to be a correct behavior. In addition, I observed that double clicking on the filmstrip image displays all the thumbnails with the same coordinates (from the same film).

#5 Updated by Pascal Obry about 1 month ago

  • Target version set to 2.6.1
  • Tracker changed from Bug to Feature
  • Status changed from In Progress to Fixed
  • % Done changed from 50 to 100

Done.

Also available in: Atom PDF