Project

General

Profile

Bug #12532

Vignetting not correctly applied

Added by Jim Robinson about 1 year ago. Updated about 1 year ago.

Status:
Closed: upstream
Priority:
Low
Assignee:
-
Category:
Darkroom
Start date:
01/07/2019
Due date:
% Done:

0%

Estimated time:
Affected Version:
git master branch
System:
all
bitness:
64-bit
hardware architecture:
amd64/x86

Description

I have prepared new vignetting lensfun data for the Laowa 7.5mm F2.0 MFT lens using method described on lensfun site. I have then used the flat field images used to prepare the lensfun data to test the corrections. If these corrections are applied by darktable to a tiff or pbm image exported from darktable straight after demosaicing and then re-importedthe vignetting is corrected very well. However if the correction is applied to the raw file within darkroom then the correction is very poor being only about 50% corrected. Interestingly both RawTherapee and UFraw have exactly the same problem! I am not sure whether it is relevant, but this is a 'dumb' lens, i.e. no lens info in the exif data, and so the relevant corrections have to be selected manually. Given that 3 raw processing programs have the same problem I have raised this issue on the lensfun list, but maybe it is that there is some shared code here. I did wonder if the crop factor (2) was relevant given that the degree of vignette correction was about half of what was expected, but that seems unlikely. I have seen this problem under both windows and ubuntu.

I attach a relevant raw file and a misc.xml which has been revised to include vignette info for the lens Venus - Laowa 7.5mm. The image was taken at F2.0.

misc.xml (30.1 KB) misc.xml updated data for lens Jim Robinson, 01/07/2019 05:13 PM
P1050531.ORF (14.7 MB) P1050531.ORF flat field image F2.0 focus infinity Jim Robinson, 01/07/2019 05:18 PM

History

#1 Updated by Roman Lebedev about 1 year ago

  • % Done changed from 0 to 20
  • Status changed from New to Incomplete

Jim Robinson wrote:

I have prepared new vignetting lensfun data for the Laowa 7.5mm F2.0 MFT lens using method described on lensfun site. I have then used the flat field images used to prepare the lensfun data to test the corrections. If these corrections are applied by darktable to a tiff or pbm image exported from darktable straight after demosaicing and then re-importedthe vignetting is corrected very well. However if the correction is applied to the raw file within darkroom then the correction is very poor being only about 50% corrected. Interestingly both RawTherapee and UFraw have exactly the same problem! I am not sure whether it is relevant, but this is a 'dumb' lens, i.e. no lens info in the exif data, and so the relevant corrections have to be selected manually. Given that 3 raw processing programs have the same problem I have raised this issue on the lensfun list, but maybe it is that there is some shared code here. I did wonder if the crop factor (2) was relevant given that the degree of vignette correction was about half of what was expected, but that seems unlikely. I have seen this problem under both windows and ubuntu.

I attach a relevant raw file and a misc.xml which has been revised to include vignette info for the lens Venus - Laowa 7.5mm. The image was taken at F2.0.

linewrapping, anyone?

I'll bet the problem is in the script that you used to generate the lensfun profiles.
Maybe try using the older, previous script.

#2 Updated by Jim Robinson about 1 year ago

But the lensfun profiles work fine on pbm and tiff files, i.e the polynomial obtained by running lens_calibrate.py is a very good fit to the actual radial intensity fall off. I have checked that the intensity fall off is identical in the demosaiced raw file and the tiff and pbm directly exported from it.

#3 Updated by Roman Lebedev about 1 year ago

  • % Done changed from 20 to 0
  • Status changed from Incomplete to Closed: upstream

Also available in: Atom PDF

Go to top