Project

General

Profile

Bug #12528

Cannot read camera white balance

Added by Alex Mozheiko about 1 year ago. Updated about 1 year ago.

Status:
Duplicate
Priority:
Low
Assignee:
-
Category:
Darkroom
Target version:
Start date:
01/06/2019
Due date:
% Done:

0%

Estimated time:
Affected Version:
git master branch
System:
Ubuntu
bitness:
64-bit
hardware architecture:
amd64/x86

Description

A regression?
There was a Darktable code revision 2 years ago following the bug I reported https://redmine.darktable.org/projects/darktable/repository/revisions/b939ed9d49322aa7d5eb27309677419e4fc31d10 1
When it was fixed I had compiled v2.3+xxxxxx and continued using it until now. This time, two years later, when I upgraded to 2.6 for good, DT showed me the old error again ‘cannot read Nikon J1 camera balance’. The stranger part is that WB is perfectly read for neighbor images of the same photo set. It fails to read WB like for every third-fifth file or so.
In order to test, I removed my library.db and data.db, as well as ./config/darktable, suspecting my old configs to be corrupted and pulled DT v2.6 from Ubuntu repository, installing new configs, but, no, it wasn’t them configs - the error repeated itself. Literally same camera, same lens, setup.
See attachments.
I wonder where did I do wrong? Was the fix transferred to subsequent DT versions >2.3?

Note: cannot yet select version 2.6.0 in the tracker, so I'm choosing GIT master instead.

_DSC8140.NEF (8.33 MB) _DSC8140.NEF Alex Mozheiko, 01/06/2019 04:42 PM
Screenshot_2019-01-06_14-24-41.png (599 KB) Screenshot_2019-01-06_14-24-41.png Alex Mozheiko, 01/06/2019 04:42 PM

Related issues

Is duplicate of darktable - Bug #12208: [2/3] Regression: huffmantable is bad for last decodeFixed05/19/2018

History

#1 Updated by Roman Lebedev about 1 year ago

  • Is duplicate of Bug #12208: [2/3] Regression: huffmantable is bad for last decode added

#2 Updated by Roman Lebedev about 1 year ago

  • Status changed from New to Duplicate

Alex Mozheiko wrote:

A regression?
There was a Darktable code revision 2 years ago following the bug I reported https://redmine.darktable.org/projects/darktable/repository/revisions/b939ed9d49322aa7d5eb27309677419e4fc31d10 1

That was actually a different issue.
That was an intentional breakage of all (most) of nikon cameras to force the affected users of affected cameras to help to cleanup the mess.
See e.g. https://www.mail-archive.com/darktable-user@lists.darktable.org/msg01282.html

When it was fixed I had compiled v2.3+xxxxxx and continued using it until now. This time, two years later, when I upgraded to 2.6 for good, DT showed me the old error again ‘cannot read Nikon J1 camera balance’. The stranger part is that WB is perfectly read for neighbor images of the same photo set. It fails to read WB like for every third-fifth file or so.
In order to test, I removed my library.db and data.db, as well as ./config/darktable, suspecting my old configs to be corrupted and pulled DT v2.6 from Ubuntu repository, installing new configs, but, no, it wasn’t them configs - the error repeated itself. Literally same camera, same lens, setup.
See attachments.
I wonder where did I do wrong? Was the fix transferred to subsequent DT versions >2.3?

You didn't, this was a regression (a rather long-lived at that :/), which is now fixed.

Note: cannot yet select version 2.6.0 in the tracker, so I'm choosing GIT master instead.

Also available in: Atom PDF

Go to top