Project

General

Profile

Bug #12525

Unhandled exception : Darktable 2.6.0.win64 on Ryzen 1600 with Radeon 560D win10home 64-bit

Added by Hans NEHER 9 months ago. Updated 2 months ago.

Status:
New
Priority:
Low
Assignee:
-
Category:
General
Target version:
Start date:
01/05/2019
Due date:
% Done:

0%

Estimated time:
Affected Version:
git stable branch
System:
Windows
bitness:
64-bit
hardware architecture:
amd64/x86

Description

Gentlemen,

Hope this is the correct spot to post an 'unhandled exception' which prevents Darktable 2.6.0. win64 from functioning?

Installed the above on an elderly dual core intel cpu notebook with win10 home and runs fine; then installed on the newer and faster AMD desktop as per above and find an unhandled exception error. Rebooted, same result : log-file attached.

The error is listed as : darktable.exe caused an Access Violation at location 00007FFA7012C6BA in module amdocl64.dll Reading from location 0000000000000020.

By all means ask if you need more info, but please realise that I'm a user, w/o much knowledge beyond (double) clicking.

Looking forward, met vriendelijke groet (dutch for 'with friendly greeting),

Hans

By the way : "Affected Version" is apparently - given the red asterisk - a required answer : would be helpful if newest versions 2.6.0 and 2.6.1 were available in that list? if one can't update the list all that often could whoever maintains this bug reporting system please add 'newest' as an entry, and - assuming users update regularly - it would be helpful if the newest version was at the top of the list?

H.

darktable_bt_7KW0UZ.txt (4.71 KB) darktable_bt_7KW0UZ.txt log file Hans NEHER, 01/05/2019 12:20 AM
darktable_bt_J7GVUZ.txt (4.72 KB) darktable_bt_J7GVUZ.txt new logfile after radeon driver update Hans NEHER, 01/05/2019 01:22 AM
darktable_bt_26QP4Z.txt (4.74 KB) darktable_bt_26QP4Z.txt log: darktable 2.6.2 reporting an exception Scott Tavares, 07/10/2019 04:18 PM

History

#1 Updated by Hans NEHER 9 months ago

Updated Radeon driver from 18.12.2 to latest 18.12.3, restarted Darktable, same problem - see new log file.
Puzzling : Radeon update now advises to update from 18.12.3 to 18.12.2 - that's a downgrade?

Regarding Affected Version : downloaded latest from Darktable website, hence not sure why I'm asked whether git stable or master branch?

#2 Updated by Ulrich Pegelow 8 months ago

From the crash report we can see that the error happens in the OpenCL driver, supposedly at an early stage of initialization. Besides of trying alternative versions of the driver you may also run darktable with option --disable-opencl.

#3 Updated by Hans NEHER 8 months ago

Dear Ulrich, thank you for the reply.

1/ In the Windows> Start Menu> Programs> darktable folder two shortcuts, one called darktable. right click & select properties, in the Shortcut tab : "C:\Program Files\darktable\bin\darktable.exe" . Tried adding the --disable-opencl bit after .exe to make " C:\Program Files\darktable\bin\darktable.exe --disable-opencl " (without the "" of course), but Windows doesn't allow to save the amended string.

2/ Opened 'Run' , copied the string plus your addition there, which started the program, so you suggestion must be correct; remains how to amend the shortcut, as creating a new shortcut with the string which works from 'Run' wasn't accepted either.

3/ Second option is to try an alternative version of the driver amdocl64.dll : File version is reported as 25.20.15011.1004 , the product version as 10.0.2766.5 and the size as 56,433,056 bytes . Presumably need to downgrade the Radeon Adrenalin software version?

Darktable 2.6.0 was released on 24 Dec 2018, would you or another person know with which Radeon Adrenalin version darktable 2.6.0 was tested, please, and more to the point : with which version of amdocl64.dll?

#4 Updated by Martin Maier 7 months ago

Hi All,

I get the same error message.

Thank you for your support.

#5 Updated by Scott Tavares 2 months ago

I have the same issue... turning off opencl is not an answer. Why is opencl and the driver for the AMD GPUs having a conflict? I have been trying to get this to work for a year and a half. Very frustrating. I understand that this is an oss project but when a very large section of your potential user base is cut off from using the software this issue should be more of a priority than anything else. Why isn't it a bigger priority to fix this?

Also available in: Atom PDF

Go to top