Project

General

Profile

Bug #12497

Image export does not work for some RAWs when Equalizer is enabled

Added by Oskar Maier about 1 year ago. Updated about 1 year ago.

Status:
Closed: invalid
Priority:
Low
Assignee:
-
Category:
Darkroom
Target version:
Start date:
12/26/2018
Due date:
% Done:

0%

Estimated time:
Affected Version:
git stable branch
System:
Ubuntu
bitness:
64-bit
hardware architecture:
amd64/x86

Description

Import a RAW taken with a Sony A7RII (A7RM2), for example http://www.rawsamples.ch/raws/sony/RAW_SONY_ILCE-7RM2.ARW
Enable the Equalizer module.
Export the image as 8 bit JPEG with quality set to 100% (quality and format might not matter)

Wait as long as you need to be convinced that export does not work.

Export did work with a RAW taken with a Sony NEX-6.

Version: 2.6.0 (from pmjdebruijn PPA) and latest master branch
Kubuntu 18.10 64bit
Intel I7 3517U, 4GB RAM, 1920*1080 Display resolution

History

#1 Updated by Roman Lebedev about 1 year ago

  • Status changed from New to Closed: invalid

Oskar Maier wrote:

Import a RAW taken with a Sony A7RII (A7RM2), for example http://www.rawsamples.ch/raws/sony/RAW_SONY_ILCE-7RM2.ARW

That one is 42 MPix.

Enable the Equalizer module.

That module is extremely computing-intensive.

Export the image as 8 bit JPEG with quality set to 100% (quality and format might not matter)

Wait as long as you need to be convinced that export does not work.

Export did work with a RAW taken with a Sony NEX-6.

This is 16Mpix, almost 3 times less.
Even assuming that there is linear dependency between image size and module's computation, it will be 3 times slower.

Version: 2.6.0 (from pmjdebruijn PPA) and latest master branch
Kubuntu 18.10 64bit
Intel I7 3517U

That's 4 threads right?

, 4GB RAM

And that is where everything goes out of the window.
The module is also extremely memory-hungry.
And since you have so low memory, and such extremely large raws, it has to process the image in tiles, which results in another (2x?) slowdown.

see `$ darktable -d dev -d perf`

, 1920*1080 Display resolution

#2 Updated by Oskar Maier about 1 year ago

Thanks for your reply and shame on me.
Here are some numbers:
Export of one image with other modules except equalizer (42MP): < 1 minute
Export of one image with lots of modules including equalizer (16MP): ~1-2 minutes
Export of one image with lots of modules including equalizer (42MP): ~40 minutes
Export of one image with lots of modules including 2 instances of the equalizer: ~ 1h 20 minutes

When exporting images in lower resolutions deactivating 'high quality resampling' in the core options speeds up things a lot (of course).

#3 Updated by Oskar Maier about 1 year ago

One more update:
the cause of the long processing time was not the processor and could be sped up significantly without new hardware. By decreasing the thumbnail cache size from 2048MB to 256MB the processing got as fast as the 16MP image (1-2 minutes per image).

Takeaway:
The pipeline scales really well with image size but processing slows down significantly (here by a factor of 20-40) when memory is insufficient

Also available in: Atom PDF

Go to top