Project

General

Profile

Bug #12492

Date filter is not working

Added by François Tissandier about 1 year ago. Updated about 1 year ago.

Status:
Fixed
Priority:
Critical
Assignee:
Category:
Lighttable
Target version:
Start date:
12/24/2018
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.4.4
System:
Ubuntu
bitness:
64-bit
hardware architecture:
amd64/x86

Description

In the lighttable, when I'm trying to select photos by table, it's not working. No effect, it's showing all the photos, no matter if I select a year, month or day.

It's for version 2.6.0 which is not listed. So I put 2.4.4, but it's in fact for the latest release.

History

#1 Updated by François Tissandier about 1 year ago

On another Ubuntu computer where I just installed version 2.6 from the PPA, the date filters are working just fine.

#2 Updated by François Tissandier about 1 year ago

Some more tests. Finally solved it. All filters were giving wrong results. In fact a simple filter on any field was acting as a "NOT" one. I probably edited a more complex filter right before, and left a NOT condition. The only problem is that it's impossible to see it. So it's not a bug, but I think it would still be nice to see the operator of the default filter.

#3 Updated by James Bowen about 1 year ago

I just experienced similar issue on Ubuntu 2.6.0 (via PPA) ... it seemed like no collections selections was working but I think the issue was the filter box was not showing multiple selection rules that were present. Instead it looked like there were no rules and adding another filter did nothing. If I repeatedly used "clear this rule" the displayed selection rule would change (but still only show one). Repeat several time until prior rules are all gone then selections seem to work.

If I then create a new set of multiple collection rules they work correctly and "stack" within the display box as expected.

It is possible this only shows up if you have a multiple rule collection filter selected at time of upgrade from 2.4.x -> 2.6.0 as I have not been able to reproduce since.

#4 Updated by Pierre Chesneau about 1 year ago

I also encountered this bug on the windows version (2.6.0). The workaround provided by James was successfull (thank you James).
I was also migrating from 2.4.X to 2.6.0. I was not using advanced filters by the time the migration was done, only a collection name filter.

#5 Updated by Pascal Obry about 1 year ago

  • % Done changed from 0 to 100
  • Target version set to 2.6.1
  • Priority changed from Low to Critical
  • Assignee set to Pascal Obry
  • Status changed from New to Fixed

This should be fixed in darktable now (will be in 2.6.1).

#6 Updated by Simao M about 1 year ago

Any chance we can have 2.6.1 soon? This broke all my collections, I need to negate them to get the images I want ;)

Thanks!

#7 Updated by Pascal Obry about 1 year ago

I understand how bad this is! We don't have planned the 2.6.1 but I'd like to have this out in March.

#8 Updated by Nicolas Auffray about 1 year ago

Before having the 2.6.1, tru to see your darktablerc and this line (with darktable closed) :

plugins/lighttable/collect/mode0=

You should have 2 on result if you have a bug in collection. Change 2 to 0 and relaunch darktable. Be sure to reset filter collections and all should work after that.

See this bug : https://redmine.darktable.org/issues/12339#change-36750

#9 Updated by Simao M about 1 year ago

Yeah that fixed it for me. Thanks

Also available in: Atom PDF

Go to top