Project

General

Profile

Feature #12479

Lens correction included in default modules (like base curve)

Added by Vincent Fregeac 7 months ago. Updated 7 months ago.

Status:
Closed: won't fix
Priority:
Low
Assignee:
-
Category:
Darkroom
Target version:
Start date:
12/18/2018
Due date:
% Done:

0%

Affected Version:
git master branch
System:
all
bitness:
64-bit
hardware architecture:
amd64/x86

Description

In my understanding, the role of the default modules is to provide a baseline to further develop the image without modifying the image beyond what the photographer would expect. As far as I know, that would be the reason why the base curve is activated by default although most base curve presets are really aggressive on the highlights. On the other hand, lens correction usually apply minor (but important) corrections without being aggressive. Considering that lens distortion is never something a photographer would want, applying the lens correction by default would make even more sense than applying the base curve by default, especially considering that most lens/body combinations have a lens correction profile while the base curve is, in most cases, a generic profile not really representative of the camera because there is not many camera-specific profile for the base curve, yet. Make sense?

History

#1 Updated by Roman Lebedev 7 months ago

  • Status changed from New to Closed: won't fix

The defaults are defauls to provide minimally viewable image, not anything else.
To get lens correction by default, create preset, and set auto apply = on.

#2 Updated by Vincent Fregeac 7 months ago

I understand the idea of the defaults but the point I was raising is the fact that the current choices (base-curve but no lens correction) is illogical whatever the way you look at the defaults.

If the purpose of the defaults is to provide a minimally viewable image, it shouldn't lead to the false impression that the image have pure white, and therefore unsalvageable, highlights because the base curve have raised the lightness beyond the threshold of human perception (a computer can differentiate 250 from 255 in RGB, but most human eyes can't).

On the other hand, if base-curve is included in the defaults, it means the actual purpose of the default is not a minimally viewable image (it's perfectly viewable without the base curve) but a minimally assessable image. Anyone who have worked on any image software knows that, contrary to pure black or pure white, poor contrast is easily fixable. So the absence of the base-curve wouldn't even affect the assessment of the image. On the other hand, few image software provide the profiled lens correction that DT or other raw developping tool provide. And even someone who have spend sometime on won't develop the reflex to ignore geometric distorsion when assessing an image (don't ask me why, it's just one of these weird quirks of the human brain).

Either way, it needs fixing: Either exclude base-curve which shouldn't be included in a minimally viewable image because of potential false-negative when assessing the image before development, or approach it as a minimally assessable image, which should include lens correction before including base-curve to avoid false-negatives caused by geometric distorsion, and potentially also exclude base-curve because, contrary to the absence of lens corrections, the absence of base-curve will not lead to false-negative in the assessment of the development baseline.

#3 Updated by Roman Lebedev 7 months ago

  • Target version set to 2.6.0

#4 Updated by Vincent Fregeac 7 months ago

Hi Roman,

I'm not sure if the fact that you set a target version means you plan to work on it despite its status still being Closed.

If you plan to work on it, I suggest moving "Lens correction" to the [basic group] since it is a basic correction (like [crop and rotate]) and it only requires to activate it most of the time (the default body/lens profile works best most of the time). Also, some denoise should be part of [basic group] since noise is something most people address more often than [highlight reconstruction] or [color reconstruction]. The module [denoise (profiled)] is, I think, the easiest to use and understand, so it would be a good candidate for a "basic denoise".

What do you think?

Also available in: Atom PDF