Project

General

Profile

Bug #12464

Darktable Windows 2.6.0rc1 fails to start with error 0xc0000142

Added by Victor Sanchez 3 months ago. Updated 3 months ago.

Status:
Fixed
Priority:
Low
Assignee:
Category:
General
Target version:
Start date:
12/13/2018
Due date:
% Done:

100%

Affected Version:
git master branch
System:
Windows
bitness:
64-bit
hardware architecture:
amd64/x86

Description

The problem has appeared in some machines (Windows 10, 64bit) but not in others. When running darktable the "shell" window will appear and then a pop-up window with the error information. It happens when run from the GUI or directly from the command windows. It happens also with darktable-cli.exe executable. In the last case, the error pops-up even before the "help" string of the command is printed.

The program does not modify anything (db for example) since one can go ahead and reinstall 2.4.4 without problems.

This is consistent with the little information available on the web, which ties this error to installation problems.

I have two computers, a laptop with an Intel graphics chipset and Windows 10, English language, and the installation worked well. The other is the main desktop, Spanish language, and NVIDIA graphics chipset. The bug shows up in this system. The problem is hard to reproduce.

Things we have tried:

1. Copied the installation directly from the "working" machine to the machine with the problem (Dave's suggestion). Did not work.
2. Used "Dependency Walker" in the machine with the problem and compared to same from a working installation (thanks Jan). No difference was detected, so no missing DLLs or packages.
3. The problem showed up in a machine with Spanish Language and one with a German installation (Blandyna's). I changed the main language to English (both for the user and for non-unicode applications), reinstalled. Still the same problem.

I inspected the registry from my "good" machine and compared it to the "bad" machine. There were some differences but they seemed, to my untrained eye, related to the different usages histories of the computers. Nothing jumped at me as weird, but then again I know very little about windows in general.

Victor

Note: in the Affected Version selector, version 2.6.0rc1 is not an option.

History

#1 Updated by Victor Sanchez 3 months ago

The problem is present in the second release candidate 2.6.0rc2

#2 Updated by M W 3 months ago

I'm also seeing this problem with both RC1 & RC2.
Under Windows 10 x64.

#3 Updated by Christian Kanzian 3 months ago

There is a discussion on this here:
https://discuss.pixls.us/t/error-code-launching-darktable/10220/44

Looks like it is a compiler option which generates code with AVX2 instructions. Some CPUs do not support this. New builds on the way, which might solve this.

#5 Updated by Pascal Obry 3 months ago

  • % Done changed from 0 to 100
  • Status changed from New to Fixed
  • Assignee set to Pascal Obry

Indeed, closing this report. The new build is fixed.

Also available in: Atom PDF