Project

General

Profile

Bug #12462

darkroom : zoom stucks with mouse wheel : 100% max or back to 200% if superior

Added by Nicolas Auffray 3 months ago. Updated 3 months ago.

Status:
Closed: won't fix
Priority:
Low
Assignee:
Category:
Darkroom
Target version:
Start date:
12/12/2018
Due date:
% Done:

0%

Affected Version:
git master branch
System:
Ubuntu
bitness:
64-bit
hardware architecture:
amd64/x86

Description

In darkroom, zoom with mouse wheel has quite strange behavior. For example, if I'm on 1600%, it's impossible to reduce zoom to intermediate levels. One step with mouse wheel revert it back directly to 200% (try several times).
Other thing, if I'm on 100% level or inferior, it's possible to zoom in or out with mouse wheel but it stops on 100%. I can't go further with mouse wheel.
Of course, it's not a bug quite disturbing as it's quick and easy to use the menu.
I'm using the last 2.6.0rc1 version. I don't know if this behavior was in darktable 2.4.4.

History

#1 Updated by Pascal Obry 3 months ago

100% -> 200% with ctrl+mouse-wheel, this is in the doc :)

For the intermediate zoom level that's just not supported, it is not a bug as it would require quite some coding to have proper rendering.

#2 Updated by Pascal Obry 3 months ago

  • Target version changed from 2.6.0 to 2.6.1
  • Assignee set to Pascal Obry

What is missing is to be able to control zoom > 200% with the mouse.

#3 Updated by Nicolas Auffray 3 months ago

Ok, I've missed the ctrl+mouse wheel in the doc.

This behavior remains counter intuitive. So it could be a feature for a future version to harmonize this on each level of zoom. So maybe changing this from bug to feature would be more appropriate. It seems I can't change that.

#4 Updated by Pascal Obry 3 months ago

  • Status changed from New to Closed: won't fix

No it is not counter intuitive, it makes sure that the zoom level is blocked at 100% to avoid looking at an image with pixels being interpolated. So nothing to fix.

#5 Updated by Nicolas Auffray 3 months ago

Ok, I didn't think about that. Thanks for your answers.

#6 Updated by Roman Lebedev 3 months ago

  • Target version changed from 2.6.1 to 2.6.0

Also available in: Atom PDF