Project

General

Profile

Bug #12447

UI is degrading in quality

Added by Roman Lebedev about 1 month ago. Updated 18 days ago.

Status:
New
Priority:
Low
Assignee:
Category:
General
Target version:
Start date:
12/07/2018
Due date:
% Done:

0%

Affected Version:
git master branch
System:
all
bitness:
64-bit
hardware architecture:
amd64/x86

Description

  1. Randomly switches to the "favorites" iop's tab
  2. "Expand one darkroom module" switch simply does not work
  3. Some buttons get stuck in highlighted state

Associated revisions

Revision 2b42f2f5
Added by Pascal Obry about 1 month ago

imageop: draw backgroud only if asked for.

Fixes #12447.

Revision d2793acd
Added by Pascal Obry 25 days ago

imageop: draw backgroud only if asked for.

Fixes #12447.

Revision 6d785899
Added by Pascal Obry 25 days ago

imageop: draw backgroud only if asked for.

Fixes #12447.

History

#1 Updated by Aurélien PIERRE about 1 month ago

2. has been broken since forever for me. It usually works on the first picture I open, then, if I switch between pictures in the darkroom, the result is random, especially when creating new instances or applying styles.

#2 Updated by Roman Lebedev about 1 month ago

Aurélien PIERRE wrote:

2. has been broken since forever for me. It usually works on the first picture I open, then, if I switch between pictures in the darkroom, the result is random, especially when creating new instances or applying styles.

Pretty sure it was working last year.
Now it is indeed just completely broken to the point of being nonexistant.

#3 Updated by Pascal Obry about 1 month ago

I never seen 1, for 2 indeed it never work :( I do not use this mode so I ddn't notice this. To be fixed and if possible before 2.6 finale. For 3 I see only the buttons to handle the duplicates. I had a look and this seems to be a Gtk issue.

#4 Updated by Pascal Obry about 1 month ago

For 2 I had the same issue because I was using reordered IOP. With standard layout, no issue. And I have fixed the issue when using custom order in commit : c6150a5f87db

#5 Updated by Pascal Obry about 1 month ago

I have fixed 3 for the multi-instance button. I don't see some others in the same case.

#6 Updated by Pascal Obry about 1 month ago

  • Category set to General
  • Assignee set to Pascal Obry
  • Target version set to 2.6.0

#7 Updated by Roman Lebedev about 1 month ago

Roman Lebedev wrote:

  1. Randomly switches to the "favorites" iop's tab
  2. "Expand one darkroom module" switch simply does not work

These still apply.
Quite distracting even for usage of 5 minutes a week for camera support purposes...

  1. Some buttons get stuck in highlighted state

The "enable" toggle is never highlighted on mouseover.

#8 Updated by Pascal Obry about 1 month ago

The "enable" toggle is never highlighted on mouseover.

And has never been, you can see this in 2.4. But i agree that it should, will try to fix that.

I cannot reproduce the two other points for now.

#9 Updated by Anonymous about 1 month ago

  • Status changed from New to Fixed
  • % Done changed from 0 to 100

#10 Updated by Pascal Obry about 1 month ago

Liquify typo fix merged. It has worked, thanks for the hint.

#11 Updated by Roman Lebedev about 1 month ago

Anonymous wrote:

Applied in changeset darktable|2b42f2f573c460ba99b96efa7afac6b0385bb5d1.

Thanks.
The other issues remain, probably.

#12 Updated by Roman Lebedev 23 days ago

  • Status changed from Fixed to New
  • % Done changed from 100 to 0

Roman Lebedev wrote:

Roman Lebedev wrote:

  1. Randomly switches to the "favorites" iop's tab
  2. "Expand one darkroom module" switch simply does not work

These still apply.
Quite distracting even for usage of 5 minutes a week for camera support purposes...

Still happen even after completely deleting ~/.config/darktable

#13 Updated by Pascal Obry 23 days ago

Really strange and disturbing as I've not read such issue reported by others. What's your OS and DE? Any info to help track this done would be nice.

#14 Updated by Roman Lebedev 23 days ago

Pascal Obry wrote:

Really strange and disturbing as I've not read such issue reported by others. What's your OS and DE? Any info to help track this done would be nice.

Debian sid, KDE.

Randomly switches to the "favorites" iop's tab

It happens every time i use space/backspace to switch between images in filmstrip.

#15 Updated by Pascal Obry 18 days ago

Still can't reproduce... Maybe an issue with a specific module. Can you list the content of your favorites iop's tab?

#16 Updated by Roman Lebedev 18 days ago

Pascal Obry wrote:

Still can't reproduce... Maybe an issue with a specific module. Can you list the content of your favorites iop's tab?

Roman Lebedev wrote:

Still happen even after completely deleting ~/.config/darktable

#17 Updated by Pascal Obry 18 days ago

Indeed, resetting darktablerc also clean-up the favorites modules... Stranges! Will continue to watch.

Also available in: Atom PDF