Project

General

Profile

Bug #12444

Inconsistency in color balance iop

Added by Masoud M 6 months ago. Updated 5 months ago.

Status:
Closed: won't fix
Priority:
Low
Assignee:
-
Category:
Darkroom
Target version:
Start date:
12/07/2018
Due date:
% Done:

0%

Affected Version:
git master branch
System:
Ubuntu
bitness:
64-bit
hardware architecture:
amd64/x86

Description

When "color control sliders" set to "HSL" or "both" modes the max value for the saturation sliders of offset/lift, gamma/power, and gain/slope is 25%. But after using RGB sliders in either "RGBL" or "both" modes, the max value becomes 100% for those saturation sliders.
Steps to reproduce:
1. Open a photo in darkroom
2. Enable color balance iop
3. Increase the saturation sliders to their max values which is 25%
4. Change "color control sliders" to "both" mode
5. Change one of RGB sliders to their max/min values
6. Now the max value of the saturation sliders are 100%

History

#1 Updated by Aurélien PIERRE 6 months ago

It's not a bug.

Saturation sliders are limited to 25 % (hard range) because that's where real-life values live. But when you edit in RGB, the saturation depends on the 3 RGB parameters and is updated live, so if you put the RGB sliders all the way to their max, the saturation is adjusted consequently. Saturation sliders have a soft-range of [0; 100] %, so once you have used high values, the sliders get resized accordingly.

What matters is the HSL <-> RGB parameters conversions are accurate and fully-reversible.

#2 Updated by Masoud M 6 months ago

I think 25% saturation is enough for offset and power but I sometimes find it not enough for slope. Isn't it better to let user increase the saturations up to 100% and then describe in the manual that they should be kept below 25%?

#3 Updated by Aurélien PIERRE 6 months ago

You can increase the saturation up to 100 % by using right-click and inputting the value > 25 % on the keyboard. I have never had to use it that strongly, so I find that keeping the hard range to 25 % offers more accuracy to control most images.

#4 Updated by Aurélien PIERRE 5 months ago

  • Status changed from New to Closed: won't fix

Also available in: Atom PDF