Project

General

Profile

Bug #12433

darktable segfault perhaps related to local copies

Added by Patrick Shanahan 6 months ago. Updated 6 months ago.

Status:
Closed: invalid
Priority:
Low
Assignee:
Category:
Darkroom
Target version:
Start date:
12/03/2018
Due date:
% Done:

0%

Affected Version:
git master branch
System:
openSUSE
bitness:
64-bit
hardware architecture:
amd64/x86

Description

getting segfaults

originally believed related to rotating image, but it appears
to only happen when working with local copies of remote files.

ref Bug #12409

opened new bug report per request from Pascal Obry

appears to be directly related to using local copy
working on non-local copies does not crash

several segfaults reported on irc/#darktable

latest attached, others:
http://wahoo.no-ip.org/~paka/247b0226b.1.gdb.txt
http://wahoo.no-ip.org/~paka/247b0226b.gdb.txt
http://wahoo.no-ip.org/~paka/d25c659ff.2.gdb.txt
http://wahoo.no-ip.org/~paka/d25c659ff.1.gdb.txt
http://wahoo.no-ip.org/~paka/d25c659ff.gdb.txt
http://wahoo.no-ip.org/~paka/a391a1518.4.gdb.txt
http://wahoo.no-ip.org/~paka/a391a1518.3.gdb.txt
http://wahoo.no-ip.org/~paka/a391a1518.2.gdb.txt
http://wahoo.no-ip.org/~paka/a391a1518.1.gdb.txt
http://wahoo.no-ip.org/~paka/a391a1518.gdb.txt
http://wahoo.no-ip.org/~paka/1e19a8d01.gdb.txt

tried darktable-asan-2.6.0rc0~git2.15719b1a5-822.1.x86_64.rpm
from darix' builds but crashes when opened. from irc/#darktable 2-12-18:
15:47:08 LebedevRI | also, everything glib is just completely broken by design, so i think │ | "ASAN_OPTIONS=check_initialization_order=1" just completely does not work

247b0226b.2.gdb.txt Magnifier (131 KB) Patrick Shanahan, 12/03/2018 12:38 AM

History

#1 Updated by Patrick Shanahan 6 months ago

dt does not segfault if local copy is made within the same session.

close dt with several images local copied, reopen dt and perform action
on a local copy image and segfault.

#2 Updated by Pascal Obry 6 months ago

We will need more information. I created 12 local copies. Exited dt and restarted it.

I then created spots, did lot of rotations from darkroom and moved the spots around and again some rotations.

No issue, no crash... So sounds like an issue on your side. Memory? OpenCL? The local copies sounds like a red-herring to me.

#3 Updated by Patrick Shanahan 6 months ago

ok, perhaps it is really a local issue. I have worked for several
days w/o it happening again. I will try things today that caused
it to happen to me and try to repeat.

I vacuumed and did integrety_check against both data.db and library.db
successfully and purged non-existing images (had 3). I now see only
one unexpected issue:
darktable on startup always reports "1 local copy has been
synchronized" but I have nothing copied locally and I see no
jpg's, orf's or nef's in ~/.cache/darktable/ and I would have
nothing else.

tks

#4 Updated by Patrick Shanahan 6 months ago

undetermined single local copy identified and resolved.

updated to build 7ea67a074

after many attempts I do not get segfault doing any of
previous conditions.

please remove as invalid

tks

#5 Updated by Pascal Obry 6 months ago

  • Assignee set to Pascal Obry
  • Status changed from New to Closed: invalid

Ok, closed then.

Also available in: Atom PDF