Project

General

Profile

Camera Support #12413

DT fails on loading white balance from Panasonic Lumix GX8

Added by Rafael Linux User 9 months ago. Updated 9 months ago.

Status:
Closed: won't fix
Priority:
Low
Assignee:
-
Category:
Darkroom
Target version:
Start date:
11/19/2018
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.4.3

Description

From some time to know, any RAW file I load in DT, begin showing a message saying "Darktable failed to load camera's white balance from filename.ARW". Not only in new RAW files, but in older processed ones.

Any suggestion?

Thank you

DSC05161.ARW (12.3 MB) DSC05161.ARW Rafael Linux User, 11/25/2018 06:43 AM

History

#1 Updated by Roman Lebedev 9 months ago

  • % Done changed from 0 to 20
  • Status changed from New to Incomplete

Perhaps you downgraded dt, or maybe modified/corrupted/truncated the raws elsewhere?

#2 Updated by Rafael Linux User 9 months ago

Well, it seems is not the case. RAWs files are intact. In fact, I have two kind of RAW files: From Sony A700 and from Panasonic GX8. I'm doubting about if it's happening on older Sony RAW files too, so today I'll test with my Sony RAW files too and will report result here.

Thank you

#3 Updated by thokster . 9 months ago

Rafael Linux User wrote:

From some time to know, any RAW file I load in DT, begin showing a message saying "Darktable failed to load camera's white balance from filename.ARW".

As far as I know original Lumix (GX8) raw files are *.RW2

#4 Updated by Rafael Linux User 9 months ago

You have reason, the ARW files are from Sony A700 (in my case) and RW2 from my Lumix GX8, so the problem is only with the ARW (Sony) RAW files. I tried to change this thread subject, but didn't find how.

I confirmed that my ARW files are not damaged nor corrupted. They can be processed with Darktable or Digikam, but Darktable shows mentioned error just when opening each ARW file.

Any suggestion?

#5 Updated by Roman Lebedev 9 months ago

Rafael Linux User wrote:

You have reason, the ARW files are from Sony A700 (in my case) and RW2 from my Lumix GX8, so the problem is only with the ARW (Sony) RAW files. I tried to change this thread subject, but didn't find how.

I confirmed that my ARW files are not damaged nor corrupted. They can be processed with Darktable or

Digikam

Did you configur it to write the metadata back into the raw files?

but Darktable shows mentioned error just when opening each ARW file.

Does that happen with the raws just copied from the camera, without loading/touching them elsewhere?

Any suggestion?

Nothing will happen until the issue can be reproduced.
Are there samples from that camera on https://raw.pixls.us/
Please upload one such broken raw (that you have just copied from the camera) here.

#6 Updated by Rafael Linux User 9 months ago

Roman Lebedev wrote:

Digikam: Did you configur it to write the metadata back into the raw files?

I verified I have not enabled that experimental function

Does that happen with the raws just copied from the camera, without loading/touching them elsewhere?

Sorry, I have not that camera yet ... :(

Nothing will happen until the issue can be reproduced.
Are there samples from that camera on https://raw.pixls.us/

I submitted one sample there just today

Please upload one such broken raw (that you have just copied from the camera) here.

Done too

Moreover, I downloaded and opened in DT the unique Sony A700 RAW file from that website and it didn't failed at loading ... so I begin to think is something related with the XMP file :I

#7 Updated by Roman Lebedev 9 months ago

  • % Done changed from 20 to 0
  • Status changed from Incomplete to Closed: won't fix

Rafael Linux User wrote:

Roman Lebedev wrote:

Digikam: Did you configur it to write the metadata back into the raw files?

I verified I have not enabled that experimental function

Well, someone did:

$ EXIV2 "/tmp/DSC05161.ARW" | grep -i software
0x000b Exif.Image.ProcessingSoftware                Ascii      14  14  digiKam-5.3.0  digiKam-5.3.0
0x0131 Exif.Image.Software                          Ascii      14  14  DSLR-A700 v04  DSLR-A700 v04
0x0000 Xmp.tiff.Software                            XmpText    13  13  digiKam-5.3.0  digiKam-5.3.0

$ exiftool "/tmp/DSC05161 (1).ARW" | grep -i software
Processing Software             : digiKam-5.3.0
Software                        : DSLR-A700 v04

#8 Updated by Rafael Linux User 9 months ago

Maybe I activated it in 5.3.0 (long time ago) version and disabled later ... is there any way to "delete" that information from RAW files?

#9 Updated by Roman Lebedev 9 months ago

Rafael Linux User wrote:

Maybe I activated it in 5.3.0 (long time ago) version and disabled later ... is there any way to "delete" that information from RAW files?

They broke it - they broke it. Be sure to complain to them.
I have no clue what they did to the files. But they should know.
They probably should write a tool to ungarble them.

Best bet - restore from backups.

#10 Updated by Rafael Linux User 9 months ago

No way to restore, no backup for those files. I think this issue is ignored by Darktable, but I'll notice this problem to the Digikam developers.

I'm sorry I notified the problem in the incorrect forum, but you solved my question taking your time and I want to give thanks to you, Roman.

;)

#11 Updated by Roman Lebedev 9 months ago

  • Target version set to 2.6.0

#12 Updated by Roman Lebedev 9 months ago

  • Tracker changed from Bug to Camera Support

Also available in: Atom PDF

Go to top