Project

General

Profile

Bug #12324

Apply lens correction module after color profiles gamma correction module

Added by Aurélien PIERRE about 1 year ago. Updated 12 months ago.

Status:
Duplicate
Priority:
Medium
Assignee:
-
Category:
Darkroom
Target version:
Start date:
09/13/2018
Due date:
% Done:

0%

Estimated time:
Affected Version:
git master branch
System:
all
bitness:
64-bit
hardware architecture:
amd64/x86

Description

When you perform a huge gamma correction on input data to adjust the dynamic range before applying color profiles, the vignetting correction performs very bad (see attachment).

The lens correction should be applied after the input color, gamma and profiles corrections.

DSCF3284.jpg (414 KB) DSCF3284.jpg Aurélien PIERRE, 09/13/2018 02:56 AM

Related issues

Is duplicate of darktable - Bug #10974: Lens correction before exposurePatch attached04/01/2016

History

#1 Updated by Roman Lebedev about 1 year ago

Aurélien PIERRE wrote:

When you perform a huge gamma correction on input data to adjust the dynamic range before applying color profiles, the vignetting correction performs very bad (see attachment).

The lens correction should be applied after the input color, gamma and profiles corrections.

The other way around, lens correction should be applied right before exposure module.

#2 Updated by Aurélien PIERRE about 1 year ago

why ? or maybe this is just an example of bad lens profile ?

#3 Updated by Roman Lebedev about 1 year ago

  • Is duplicate of Bug #10974: Lens correction before exposure added

#4 Updated by Roman Lebedev about 1 year ago

  • Status changed from New to Duplicate

#5 Updated by Roman Lebedev about 1 year ago

Aurélien PIERRE wrote:

why ? or maybe this is just an example of bad lens profile ?

Because if you change black level in exposure module, vignetting correction will already be incorrect.

#6 Updated by Aurélien PIERRE about 1 year ago

oh you are right, on this picture, I changed the black level in exposure too. Actually, the culprit it's not the gamma. Well, that's an easy change to make.

#7 Updated by Roman Lebedev 12 months ago

  • Target version set to 2.6.0

Also available in: Atom PDF

Go to top