Project

General

Profile

Bug #12320

Since > x11-drivers/nvidia-drivers-396.24-r1 opencl does not work anymore

Added by Axel Gerber 7 months ago. Updated 6 months ago.

Status:
Closed: won't fix
Priority:
Low
Assignee:
-
Category:
OpenCL
Target version:
Start date:
09/09/2018
Due date:
% Done:

0%

Affected Version:
2.4.4
System:
other GNU/Linux
bitness:
64-bit
hardware architecture:
amd64/x86

Description

Dear all,

I am quite sure, this issue isn't a darktable bug, so forgive me, if, with this background I shouldn't have had opened here. Just I am not good enough to nail it down in nvidia bug tracker, as I get confused by the somehow matching other reports I saw there and cannot confirm with me.

I am using gentoo linux and dt-2.4.4 as well as the git-master-branch. They all work fine.

My GPU is an nvidia GTX1060

The driver mentioned in the subject (396.24-r1) was the last, which worked fine with opencl (even though recently I observed some obscure slowness in screenupdate, when I drag some windows on top of dt)

Beginning from nvidia-drivers-396.45 I get below issue when I check with -cltest or -d opencl

[opencl_init] found opencl runtime library 'libOpenCL'[opencl_init] opencl library 'libOpenCL' found on your system and loaded
[opencl_init] could not get platforms: -1001
[opencl_init] FINALLY: opencl is NOT AVAILABLE on this system.
[opencl_init] initial status of opencl enabled flag is OFF.

Now the driver matured to 396.54 and they deleted former 396-versions so I have to go back to 390.87. In that case opencl works right away without any further changes.

I tried to check whether files or links are missing or being weired, but cannot identify the culprit.

Is there a help?

Cheers
AxelG

History

#1 Updated by Christian Kanzian 7 months ago

Did you use nvidia packages from your distribution?

In this case there might be separate packages for the driver and other stuff like opencl. To me it happened several times that this additional opencl related packages were not upgraded proberly. I needed to remove all nvidia related packages first and then had luck by reinstalling all packages.

#2 Updated by Axel Gerber 7 months ago

Dear Christian,

yes I use nvidia-drivers from gentoo tree (which finally loads from original servers, that's the sense of gentoo)

There is no real (just a virtual) other package, related to opencl and yes, I updated, to no avail. The last one is just the selector for opencl, so there is:
  • app-eselect/eselect-opencl (the selector)
  • virtual/opencl (the virtual)

Currently as needed for the downgrade to -390, I uninstalled all nvidia-cuda packages, which I also updated priorly with the 396

OFF TOPIC:
when I reply to an email of this system, does it show up here propperly?

#3 Updated by Aurélien PIERRE 7 months ago

  • Status changed from New to Closed: won't fix

It seems like an issue with the driver, you should contact the manager of the faulty package from your distro. I don't think there is much we can do here since darktable found the libOpenCl.so file properly and the driver version seems like a release candidiate.

#4 Updated by Roman Lebedev 6 months ago

  • Target version set to 2.6.0

Also available in: Atom PDF