Project

General

Profile

Bug #12315

Hard set drawn mask opacity and lock them for safety

Added by Aurélien PIERRE about 1 year ago. Updated 10 months ago.

Status:
Fixed
Priority:
Low
Assignee:
-
Category:
Masks
Target version:
Start date:
09/07/2018
Due date:
% Done:

100%

Estimated time:
Affected Version:
git master branch
System:
all
bitness:
64-bit
hardware architecture:
amd64/x86

Description

Using drawn masks extensively is really annoying, even if Ctrl+Z makes it somewhat bearable. The main reason is, on larger photos, there is a lag between the masks parameters setting and the rendering/feedback (due to the recomputation of the updated preview) during which you can still input settings in a blind way.

Problem 1 :
In the darkroom, when zooming on the image preview with the mouse wheel, if you don't pay attention and hover one active mask with the cursor, you end up increasing or decreasing the drawn mask (or its transition) instead of zooming the preview. Same when you click and drag to pan the preview, 1/2 of the time, you grab a mask (especially when they are large). Notice that it's necessary to move the preview with masks active when you need to fine-tune the contours of large masks.

Solution 1 :
Define a key combination that would lock the mask size and position to avoid errors.

Problem 2 :
In the darkroom, setting the mask opacity with Ctrl+ Mouse wheel is too much of hits and misses, due, one more time, to the lag between the setting and the output. You never get the right opacity on the first try, and need to wait for the preview rendering to finish until you get the output.

Solution 2 :
Allow to hard set the opacity percent value from the keyboard in the left column, in the masks manager.

History

#1 Updated by Aurélien PIERRE about 1 year ago

Aaaah sorry, I did a duplicate of myself : #11845

#2 Updated by Aurélien PIERRE about 1 year ago

  • Status changed from New to Closed: upstream

#3 Updated by Roman Lebedev 12 months ago

  • Target version set to 2.6.0

#4 Updated by Roman Lebedev 10 months ago

  • % Done changed from 0 to 100
  • Status changed from Closed: upstream to Fixed

Not what "closed: upstream" means.

Also available in: Atom PDF

Go to top