Project

General

Profile

Bug #12314

segfault when selection preset in "collect images" module

Added by Antoine Beaupré 2 months ago. Updated 2 months ago.

Status:
New
Priority:
Low
Assignee:
-
Category:
Lighttable
Target version:
Start date:
09/06/2018
Due date:
% Done:

0%

Affected Version:
2.4.4
System:
Debian
bitness:
64-bit
hardware architecture:
amd64/x86

Description

I have made a preset to look for images that were exported (tag: darktable|exported) and in the current year (film roll: /home/anarcat/Photos/2018/%). I saved the preset and switched to something else. Then selecting the preset again crashed the whole application with a segfault.

segfault at 0 ip 0000000000000000 sp 00007fff697e3228 error 14 in darktable[559eac8e2000+1000] 

Backtrace is attached, it seems to be crashing in a signal handler called below dt_collection_update_query.

This is Debian testing/buster (upcoming stable 10), running from an up to date Debian package. I'd be happy to throw a debugger in there and dig deeper given some direction.

Thanks!

darktable_bt_UOE5OZ.txt Magnifier (48 KB) Antoine Beaupré, 09/06/2018 01:58 AM

History

#1 Updated by Antoine Beaupré 2 months ago

Note that I'm not completely sure of the preset settings: that's only from memory. I can't figure out how to find the settings again because, well, i can't load them at all (that segfault is 100% reproducible for me) and I haven't been able to find where that's stored in the database: I found the presets table in the data.db sqlite database, but there doesn't seem to be anything in that row about which parameters are used for the preset...

Also: I tried to reproduce by re-creating another preset with the same parameters, and somehow that doesn't trigger the bug. So maybe those aren't the exact parameters.

Also available in: Atom PDF