Project

General

Profile

Camera Support #12284

Canon T7i (800D) not automatically recognized in the lens correction module.

Added by Jonas Pastoreli Batista about 1 year ago. Updated 12 months ago.

Status:
Closed: upstream
Priority:
Low
Assignee:
-
Category:
Darkroom
Target version:
Start date:
08/06/2018
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.4.4

Description

When I open the lens module does not appear the Canon T7i camera. it's not on the list either.
I edited the archive "slr-canon.xml" to put de T7i and the lens module worked as expected.

<camera>
<maker>Canon</maker>
<model>Canon EOS Rebel T7i</model>
<model lang="en">EOS Rebel T7i</model>
<mount>Canon EF-S</mount>
<cropfactor>1.613</cropfactor>
</camera>

Attached the edited file.

Locate of archive on Windows 10 Pro 64bits: C:\Program Files\darktable\share\lensfun\version_1

slr-canon.xml (477 KB) slr-canon.xml Jonas Pastoreli Batista, 08/06/2018 11:16 PM

History

#1 Updated by Roman Lebedev about 1 year ago

  • Status changed from New to Closed: upstream

Please submit that to the lensfun, which is the library darktable uses for all the lens correction stuff.
https://www.darktable.org/about/faq/#faq-external-deps

#2 Updated by Jonas Pastoreli Batista about 1 year ago

Thanks Roman for your guidance!
LensFun stable release is 0.3.2 (db version 2) (Alpha 0.3.95).
In this version of the LensFun already exists the T7i, so what remains is to wait for a new version of the darktable with the updated LensFun.
Best Regards.

Jonas

#3 Updated by Roman Lebedev 12 months ago

  • Target version set to 2.6.0

Also available in: Atom PDF

Go to top