Project

General

Profile

Bug #12271

Enabling contrast, brightness and saturation grouping is affecting image

Added by Craig Parkinson 3 months ago. Updated about 1 month ago.

Status:
Closed: won't fix
Priority:
Low
Assignee:
-
Category:
Darkroom
Target version:
Start date:
07/24/2018
Due date:
% Done:

0%

Affected Version:
2.4.1
System:
Mac OS X
bitness:
64-bit
hardware architecture:
amd64/x86

Description

I've only noticed this on the attached RAW file, but in version 2.4.1 of Darktable, when you enable the brightness, contrast and saturation grouping tools the image histogram and preview is changed, even though no changes to the sliders have occurred. See the attached screenshots for an example.

IMG_9568.CR2.xmp (5.36 KB) Craig Parkinson, 07/24/2018 05:28 PM

Screen Shot 2018-07-24 at 15.20.46.png (3.15 MB) Craig Parkinson, 07/24/2018 05:30 PM

IMG_9568.CR2 (20 MB) Craig Parkinson, 07/24/2018 05:32 PM

History

#1 Updated by Christian Kanzian 3 months ago

I think that is per design.

darktable does not clamp color values to valid values by default. (https://www.darktable.org/usermanual/en/color_management.html#darktable_color_spaces)
Moduls are working in different color spaces and the conversion could cause such "artefacts" (https://www.darktable.org/usermanual/en/color_management.html#possible_color_artifacts).
The conversion takes place as soon as a single modul is turn on which is working in Lab color space.

You can try to turn on gamut cliping in the "input color profile" module like descripted in the manual or in this video tutorial:
https://www.youtube.com/watch?v=rkM9n7IkDR0

Does this help?

#2 Updated by Aurélien PIERRE about 1 month ago

  • Status changed from New to Closed: won't fix

You have to either disable the base curve module or enable the standard color matrix in the input color profile module, or alternatively clip the gamut to sRGB. See https://www.darktable.org/usermanual/en/color_group.html#input_color_profile

The base curve module is a legacy way to reproduce quickly the in-camera color profile, performing a non-linear operation early in the pixelpipe that affects lightness, contrast and saturation all at once. It is intended to correct the standard color matrix in a sRGB space. Here, you are using an enhanced color matrix (which is a more accurate way to calibrate your camera sensor). So the base curve module is only messing the color matrix in this case.

The brightness, contrast and saturation module does essentially the same thing but later in the pixelpipe.

The new way to reproduce the in-camera settings is using the darktable-chart tool. It gives a better separation of color and luminance handling.

#3 Updated by Roman Lebedev about 1 month ago

  • Target version set to 2.6.0

Also available in: Atom PDF