Project

General

Profile

Bug #12209

Bug #11581: Huffmantable is broken.

[3/3] Regression: nikon lossy after split raw support are completely broken.

Added by Roman Lebedev 3 months ago.

Status:
New
Priority:
Medium
Assignee:
Category:
-
Target version:
-
Start date:
05/19/2018
Due date:
% Done:

0%

Affected Version:
git master branch
System:
all
bitness:
64-bit
hardware architecture:
amd64/x86

Description

Copied from https://github.com/darktable-org/rawspeed/issues/129

The LUT code assumes that all values are actually lenghts, and are smaller than 16, which isn't the case for nikon lossy-after-split raws.


Related issues

Duplicated by darktable - Bug #12153: Yet another nikon "lossy after split" raw Duplicate 04/24/2018
Duplicated by darktable - Bug #11791: Nikon D3400: failed to read camera white balance information Duplicate 10/28/2017
Duplicated by darktable - Bug #11899: Failed to read camera white balance information from xxx.NEF on some pics from Nikon1 J1 Duplicate 01/01/2018
Duplicated by darktable - Camera Support #11949: Nikon D5600 Raw Files >ISO 10000 not loading, white balance reading error Duplicate 01/20/2018
Duplicated by darktable - Bug #12047: darktake no longer reading Nikon D5500 Photos properly Duplicate 03/03/2018
Duplicated by darktable - Bug #12152: Failed to read white balance information from NEF (D5500 RAW) Duplicate 04/24/2018
Duplicated by darktable - Bug #11923: Unable to load white balance Duplicate 01/12/2018
Duplicated by darktable - Bug #12243: "Failed to read white balance information" on some NEF images Duplicate 06/24/2018

History

#1 Updated by Roman Lebedev 3 months ago

  • Duplicated by Bug #12153: Yet another nikon "lossy after split" raw added

#2 Updated by Roman Lebedev 3 months ago

  • Duplicated by Bug #11791: Nikon D3400: failed to read camera white balance information added

#3 Updated by Roman Lebedev 3 months ago

  • Duplicated by Bug #11899: Failed to read camera white balance information from xxx.NEF on some pics from Nikon1 J1 added

#4 Updated by Roman Lebedev 3 months ago

  • Duplicated by Camera Support #11949: Nikon D5600 Raw Files >ISO 10000 not loading, white balance reading error added

#5 Updated by Roman Lebedev 3 months ago

  • Duplicated by Bug #12047: darktake no longer reading Nikon D5500 Photos properly added

#6 Updated by Roman Lebedev 3 months ago

  • Duplicated by Bug #12152: Failed to read white balance information from NEF (D5500 RAW) added

#7 Updated by Roman Lebedev 3 months ago

  • Duplicated by Bug #11923: Unable to load white balance added

#8 Updated by Roman Lebedev about 2 months ago

  • Duplicated by Bug #12243: "Failed to read white balance information" on some NEF images added

Also available in: Atom PDF