Project

General

Profile

Camera Support #12201

Sony ILCE-6500: white balance presets

Added by Mikołaj Chwalisz about 1 month ago. Updated 21 days ago.

Status:
Fixed
Priority:
Low
Category:
-
Target version:
-
Start date:
05/17/2018
Due date:
% Done:

100%

Affected Version:
2.4.3

Description

I have added missing white balance presets for Sony ILCE-6500 in https://github.com/darktable-org/darktable/pull/1641

Please, let me know if something is missing.

2018-05-22 v1.05.arw (23.8 MB) Mikołaj Chwalisz, 05/22/2018 10:31 PM

Associated revisions

Revision bae13969
Added by Stefan Schöfegger 21 days ago

Merge pull request #1641 from mchwalisz/master

Add Sony ILCE-6500 white balance presets, fixes #12201

History

#1 Updated by Stefan Schöfegger 29 days ago

  • Assignee set to Stefan Schöfegger

#2 Updated by Mikołaj Chwalisz 29 days ago

Yes, I get the same for all images. However, I recently updated my camera to firmware version 1.05 and I see the values changed. They are much closer to what you have posted on github.

darktable/tools/extract_wb 2018-05-22\ v1.05.arw 
  { "Sony", "ILCE-6500", Unknown             , 0, { 2.62109375, 1, 1.55078125, 0 } },
  { "Sony", "ILCE-6500", Daylight            , 0, { 2.6171875, 1, 1.74609375, 0 } },
  { "Sony", "ILCE-6500", Shade               , 0, { 3.08203125, 1, 1.4375, 0 } },
  { "Sony", "ILCE-6500", Cloudy              , 0, { 2.81640625, 1, 1.6015625, 0 } },
  { "Sony", "ILCE-6500", Tungsten            , 0, { 1.65625, 1, 3.16796875, 0 } },
  { "Sony", "ILCE-6500", WarmWhiteFluorescent, 0, { 1.921875, 1, 3.12109375, 0 } },
  { "Sony", "ILCE-6500", CoolWhiteFluorescent, 0, { 2.4453125, 1, 2.57421875, 0 } },
  { "Sony", "ILCE-6500", DayWhiteFluorescent , 0, { 2.546875, 1, 1.84375, 0 } },
  { "Sony", "ILCE-6500", DaylightFluorescent , 0, { 2.83203125, 1, 1.67578125, 0 } },
  { "Sony", "ILCE-6500", Flash               , 0, { 2.93359375, 1, 1.59765625, 0 } },
  { "Sony", "ILCE-6500", "2500K"             , 0, { 1.4453125, 1, 3.83203125, 0 } },
  { "Sony", "ILCE-6500", "3200K"             , 0, { 1.83984375, 1, 2.7421875, 0 } },
  { "Sony", "ILCE-6500", "4500K"             , 0, { 2.375, 1, 1.96875, 0 } },
  { "Sony", "ILCE-6500", "6000K"             , 0, { 2.79296875, 1, 1.6171875, 0 } },
  { "Sony", "ILCE-6500", "8500K"             , 0, { 3.23046875, 1, 1.36328125, 0 } },


darktable/tools/extract_wb 2018-01-28\ v1.04.arw 
  { "Sony", "ILCE-6500", Unknown             , 0, { 2.30078125, 1, 1.98828125, 0 } },
  { "Sony", "ILCE-6500", Daylight            , 0, { 2.49609375, 1, 1.80859375, 0 } },
  { "Sony", "ILCE-6500", Shade               , 0, { 2.9375, 1, 1.48828125, 0 } },
  { "Sony", "ILCE-6500", Cloudy              , 0, { 2.68359375, 1, 1.65625, 0 } },
  { "Sony", "ILCE-6500", Tungsten            , 0, { 1.578125, 1, 3.28125, 0 } },
  { "Sony", "ILCE-6500", WarmWhiteFluorescent, 0, { 1.83203125, 1, 3.23046875, 0 } },
  { "Sony", "ILCE-6500", CoolWhiteFluorescent, 0, { 2.33203125, 1, 2.6640625, 0 } },
  { "Sony", "ILCE-6500", DayWhiteFluorescent , 0, { 2.42578125, 1, 1.91015625, 0 } },
  { "Sony", "ILCE-6500", DaylightFluorescent , 0, { 2.69921875, 1, 1.734375, 0 } },
  { "Sony", "ILCE-6500", Flash               , 0, { 2.796875, 1, 1.65625, 0 } },
  { "Sony", "ILCE-6500", "2500K"             , 0, { 1.37890625, 1, 3.96875, 0 } },
  { "Sony", "ILCE-6500", "3200K"             , 0, { 1.75390625, 1, 2.8359375, 0 } },
  { "Sony", "ILCE-6500", "4500K"             , 0, { 2.265625, 1, 2.0390625, 0 } },
  { "Sony", "ILCE-6500", "6000K"             , 0, { 2.6640625, 1, 1.671875, 0 } },
  { "Sony", "ILCE-6500", "8500K"             , 0, { 3.078125, 1, 1.41015625, 0 } },

Should I update pull request to match the firmware v1.05?

#3 Updated by Stefan Schöfegger 28 days ago

Yes, please update pull request

#4 Updated by Mikołaj Chwalisz 28 days ago

Pull request is updated to the values I got from v1.05

#5 Updated by Stefan Schöfegger 21 days ago

  • % Done changed from 70 to 100
  • Status changed from Patch attached to Fixed

Also available in: Atom PDF