Project

General

Profile

Bug #12152

Failed to read white balance information from NEF (D5500 RAW)

Added by Huy Hoang over 1 year ago. Updated 12 months ago.

Status:
Duplicate
Priority:
Low
Assignee:
-
Category:
Darkroom
Target version:
Start date:
04/24/2018
Due date:
% Done:

0%

Estimated time:
Affected Version:
git master branch
System:
Ubuntu
bitness:
64-bit
hardware architecture:
amd64/x86

Description

I don't have problem opening the NEF files from my D5500, but a particular RAW file from dpreview site threw the error message and couldn't be opened. Not sure if the file is corrupted or something with DT, submitting this bug report anyway in case it's something that needs to be worked on.

The offending file (ISO 6400 sample of D5500):
https://www.dpreview.com/reviews/image-comparison/download-image?s3Key=d2d45d35ad1f457ebca3c16d65d1666e.nef

My darktable version is 2.5.0+333-g1f26b4f-dirty


Related issues

Related to darktable - Bug #12153: Yet another nikon "lossy after split" raw Duplicate04/24/2018

Is duplicate of darktable - Bug #12209: [3/3] Regression: nikon lossy after split raw support are completely broken.Fixed05/19/2018

History

#2 Updated by Huy Hoang over 1 year ago

error message from the CLI:

[rawspeed] (DSC_0093.NEF) void rawspeed::HuffmanTable::setCodeValues(const rawspeed::Buffer&), line 176: Corrupt Huffman. Code value 92 is bigger than 16
[temperature] failed to read camera white balance information from `DSC_0093.NEF'!
allocation failed???

#3 Updated by Roman Lebedev over 1 year ago

  • Is duplicate of Bug #11581: Huffmantable is broken. added

#4 Updated by Roman Lebedev over 1 year ago

  • Status changed from New to Duplicate

I should probably look into partially reverting that problematic commit. Should've done that a while ago.

#5 Updated by Huy Hoang over 1 year ago

Just saw your bug report and call for NEF lossy-after-split samples :-)
https://github.com/darktable-org/rawspeed/issues/100

Let me know what I can do to help with testing. Thanks much.

#6 Updated by Roman Lebedev over 1 year ago

  • Related to Bug #12153: Yet another nikon "lossy after split" raw added

#7 Updated by Roman Lebedev over 1 year ago

  • Is duplicate of Bug #12209: [3/3] Regression: nikon lossy after split raw support are completely broken. added

#8 Updated by Roman Lebedev over 1 year ago

  • Is duplicate of deleted (Bug #11581: Huffmantable is broken.)

#9 Updated by Roman Lebedev 12 months ago

  • Target version set to 2.6.0

Also available in: Atom PDF

Go to top