Project

General

Profile

Bug #12150

DT 2.4.2 on macOS 10.12 (Sierra) wrong colors opening NEF files

Added by Giacomo Monari 5 months ago. Updated 29 days ago.

Status:
Closed: invalid
Priority:
Low
Assignee:
-
Category:
General
Target version:
Start date:
04/23/2018
Due date:
% Done:

0%

Affected Version:
2.4.2
System:
Mac OS X
bitness:
64-bit
hardware architecture:
amd64/x86

Description

Hi,

I just upgraded from Mac OS X 10.9 with Darktable 2.2 to macOS 10.12 and Darktable 2.4.2 and DT is acting very strange:
all the files I open (NEF or JPEG) have all the colors "altered" and I can't get it working properly.

If I open a new NEF file, the history is the default:

3-base curve
2-sharpen
1-orientation
0-original

In lightable and darkroom, all the colors are "un-natural".

I can't explain it very well so I decided to attach a screenshot of what I see in darktable (on the left, the view in darktable, on the right the jpg file of the same photo).

BUT...
If I export the imagine: everything is fine and the colors are normal.

What am I doin'g wrong?

OS: macOS 10.12 Sierra
Darktable: 2.4.2
Camera: Nikon D3100

Thank you so much

Darktable-wrong-colors.png - How I see the colors inside Darktable (1.42 MB) Giacomo Monari, 04/23/2018 02:30 AM

2018-05-21_example-wrong-colors.png - Example (1.44 MB) Giacomo Monari, 05/22/2018 11:03 AM

History

#1 Updated by Giacomo Monari 4 months ago

Hi, I'm happy that yesterday I managed to solve this issue of mine.
It's a very easy fix... I knew it but I didn't know what I needed to do. I'll write this down in case anyone hit the same problem.

Never had a problem with Darktable on Mac OSX Mavericks 10.9. Simply installed it and that was it.
When I upgraded the os to 10.12 Sierra, installed Darktable, the colors of the image (both in the miniatures of lighttable view and in edit mode in darktable view) were totally wrong...but... when exported, the image was correctly displayed.

See the attachment: on the top, the raw file in darktable, below the same picture inside the Preview app.

To fix this:
go in the darktable view, in the bottom panel click right on the Soft Proof tool (https://www.darktable.org/usermanual/en/darkroom_bottom_panel.html#softproof) and select "sRGB" for the display profile entry.

It should already be like that but in my case...it wasn't :)

This ticket can now be closed.

#2 Updated by Tobias Ellinghaus 4 months ago

  • Status changed from New to Closed: invalid

Let me guess, you had BRG selected there? :-)

#3 Updated by Giacomo Monari 4 months ago

Exactly!

#4 Updated by Roman Lebedev 29 days ago

  • Target version set to 2.6.0

Also available in: Atom PDF