Project

General

Profile

Bug #12140

EXIF data sometimes disappears when exporting as JPG

Added by nadim ahmed 6 months ago. Updated about 2 months ago.

Status:
Closed: invalid
Priority:
Low
Assignee:
-
Category:
Lighttable
Target version:
Start date:
04/15/2018
Due date:
% Done:

0%

Affected Version:
2.4.2
System:
Windows
bitness:
64-bit
hardware architecture:
amd64/x86

Description

I have noticed that when exporting an image in darktable as a JPEG file, it sometimes does not include the EXIF data.

I was editing a file, and exported it to JPEG. I then decided that I wanted to add a vignette to it and exported that file as well. When I was checking the files in FastStone Image Viewer, I noticed that the first file had no EXIF data, while the second one had. I did not change any of the options in the export box.

I don't know if this is of any help, in case the same library is being used, but I have also encountered this using Gimp 2.10 RC1. I am a new user of darktable, so I only started using it with the current version of 2.4.2.

darktablenoexif.png - Image showing no EXIF data (77.4 KB) nadim ahmed, 04/15/2018 01:06 PM

darktablehasexif.png - Same Image after Vignetting showing EXIF data (58.6 KB) nadim ahmed, 04/15/2018 01:06 PM

History

#1 Updated by Tobias Ellinghaus 6 months ago

Did you use masks in the image? Those can become quite big. The problem is that XMP data inside JPEGs has a size limit that libexiv2 can't deal with. Maybe that is what's happening for you? Please have a look in the log file [0] and see if darktable complains about something after you exported the image.

[0] https://www.darktable.org/about/faq/#faq-windows-logs

#2 Updated by nadim ahmed 6 months ago

Tobias Ellinghaus wrote:

Did you use masks in the image? Those can become quite big. The problem is that XMP data inside JPEGs has a size limit that libexiv2 can't deal with. Maybe that is what's happening for you? Please have a look in the log file [0] and see if darktable complains about something after you exported the image.

[0] https://www.darktable.org/about/faq/#faq-windows-logs

I have not used any masks at all. It was very simple edits. Orientation, sharpen, base curve and "crop and rotate". I noticed that the first time I exported the file, it kept the EXIF data, I exported the image again without any changes and it did not have the EXIF data. Output from the log file is shown below.

========================================
version: darktable 2.4.2
start: 2018:04:21 21:56:23

[dt_pthread_create] info: bumping pthread's stacksize from 0 to 262144
[dt_pthread_create] info: bumping pthread's stacksize from 0 to 262144
[dt_pthread_create] info: bumping pthread's stacksize from 0 to 262144
[dt_pthread_create] info: bumping pthread's stacksize from 0 to 262144
[dt_pthread_create] info: bumping pthread's stacksize from 0 to 262144
[dt_pthread_create] info: bumping pthread's stacksize from 0 to 262144
[dt_pthread_create] info: bumping pthread's stacksize from 0 to 262144
[dt_pthread_create] info: bumping pthread's stacksize from 0 to 262144
[dt_pthread_create] info: bumping pthread's stacksize from 0 to 262144
[dt_pthread_create] info: bumping pthread's stacksize from 0 to 262144
[dt_pthread_create] info: bumping pthread's stacksize from 0 to 262144

  • (darktable.exe:5860): WARNING **: [Lensfun] C:\Users\nadim\AppData\Local\lensfun\compact-panasonic.xml:337:50: <field_of_view> tag is deprecated. Use <real-focal-length> instead
  • (darktable.exe:5860): WARNING **: [Lensfun] C:\Users\nadim\AppData\Local\lensfun\compact-panasonic.xml:339:47: <field_of_view> tag is deprecated. Use <real-focal-length> instead
  • (darktable.exe:5860): WARNING **: [Lensfun] C:\Users\nadim\AppData\Local\lensfun\compact-panasonic.xml:341:50: <field_of_view> tag is deprecated. Use <real-focal-length> instead
  • (darktable.exe:5860): WARNING **: [Lensfun] C:\Users\nadim\AppData\Local\lensfun\compact-panasonic.xml:343:51: <field_of_view> tag is deprecated. Use <real-focal-length> instead
  • (darktable.exe:5860): WARNING **: [Lensfun] C:\Users\nadim\AppData\Local\lensfun\compact-panasonic.xml:345:51: <field_of_view> tag is deprecated. Use <real-focal-length> instead
  • (darktable.exe:5860): WARNING **: [Lensfun] C:\Users\nadim\AppData\Local\lensfun\compact-panasonic.xml:347:51: <field_of_view> tag is deprecated. Use <real-focal-length> instead
  • (darktable.exe:5860): WARNING **: [Lensfun] C:\Users\nadim\AppData\Local\lensfun\rf-leica.xml:17:43: Unknown element <cci>!

invalid type value detected in Image::printIFDStructure: 0
invalid type value detected in Image::printIFDStructure: 0
invalid type value detected in Image::printIFDStructure: 0
invalid type value detected in Image::printIFDStructure: 0
invalid type value detected in Image::printIFDStructure: 0
invalid type value detected in Image::printIFDStructure: 0
invalid type value detected in Image::printIFDStructure: 0
invalid type value detected in Image::printIFDStructure: 0
invalid type value detected in Image::printIFDStructure: 0
invalid type value detected in Image::printIFDStructure: 0
invalid type value detected in Image::printIFDStructure: 0
invalid type value detected in Image::printIFDStructure: 0
invalid type value detected in Image::printIFDStructure: 0
invalid type value detected in Image::printIFDStructure: 0
invalid type value detected in Image::printIFDStructure: 0
invalid type value detected in Image::printIFDStructure: 0
invalid type value detected in Image::printIFDStructure: 0
invalid type value detected in Image::printIFDStructure: 0
invalid type value detected in Image::printIFDStructure: 0
invalid type value detected in Image::printIFDStructure: 0
invalid type value detected in Image::printIFDStructure: 0
invalid type value detected in Image::printIFDStructure: 0
invalid type value detected in Image::printIFDStructure: 0
invalid type value detected in Image::printIFDStructure: 0
invalid type value detected in Image::printIFDStructure: 0
invalid type value detected in Image::printIFDStructure: 0
[export_job] exported to `C:\Users\nadim\Pictures\700d\20180418 - sun and moon/darktable_exported/IMG_3136.jpg'
invalid type value detected in Image::printIFDStructure: 0
[exiv2] C:\Users\nadim\Pictures\700d\20180418 - sun and moon/darktable_exported/IMG_3136_01.jpg: C:\Users\nadim\Pictures\700d\20180418 - sun and moon/darktable_exported/IMG_3136_01.jpg: Failed to open file (w+b): Permission denied (errno = 13)
invalid type value detected in Image::printIFDStructure: 0
[xmp_attach] C:\Users\nadim\Pictures\700d\20180418 - sun and moon/darktable_exported/IMG_3136_01.jpg: caught exiv2 exception 'C:\Users\nadim\Pictures\700d\20180418 - sun and moon/darktable_exported/IMG_3136_01.jpg: Failed to open file (w+b): Permission denied (errno = 13)'
[export_job] exported to `C:\Users\nadim\Pictures\700d\20180418 - sun and moon/darktable_exported/IMG_3136_01.jpg'

end: 2018:04:21 22:10:30 ========================================

#3 Updated by nadim ahmed 6 months ago

I think I have found the culprit. It seems to be because I have Faststone image viewer up. When I don't have it running, then the files have the EXIF data, but when I am using it, then they don't have the EXIF data.

#4 Updated by Marek Potocki 5 months ago

I have same problem with 2.4.3. On export multiple files sometimes (not always) one picture hasn't XMP/EXIF information. Re-export solving problem.

#5 Updated by Tobias Ellinghaus 5 months ago

  • Status changed from New to Closed: invalid

nadim ahmed wrote:

I think I have found the culprit. It seems to be because I have Faststone image viewer up. When I don't have it running, then the files have the EXIF data, but when I am using it, then they don't have the EXIF data.

On Windows only one program can have a file open at any given time (AFAIK). So if Faststone manages to grab the file after it has been exported but before the metadata was written we have a problem.

I'm setting this as "Invalid" for lack of any better option. I agree that it sucks, and it might be possible to circumvent that by not writing the file to disk and open it again but instead keep it in memory, but I am not sure if libexiv2 supports that.

#6 Updated by Roman Lebedev about 2 months ago

  • Target version set to 2.6.0

Also available in: Atom PDF