Project

General

Profile

Bug #12077

haze removal

Added by Peter M 3 months ago. Updated about 2 months ago.

Status:
New
Priority:
Low
Assignee:
-
Category:
Darkroom
Target version:
-
Start date:
03/12/2018
Due date:
% Done:

0%

Affected Version:
2.4.1
System:
Windows
bitness:
64-bit
hardware architecture:
amd64/x86

Description

something strange happens while using haze removal. These are two settings of strength: 0.96 and 0.59. I get horizontal and vertical lines that are becoming visible with strength above 0.20 What is really strange that vertical line changes it position depending on strength. Samples are just most visible part cut from whole photo. If needed, I can upload original RAW with xmp.

strength96.PNG (203 KB) Peter M, 03/12/2018 11:22 PM

strength59.PNG (225 KB) Peter M, 03/12/2018 11:22 PM

haze_compare.PNG - screen capture with DT and photo viewer (1.79 MB) Peter M, 04/13/2018 11:30 PM

P1410391.RW2.xmp (4.23 KB) Peter M, 04/13/2018 11:31 PM

P1410391.RW2 - original RAW (18.8 MB) Peter M, 04/13/2018 11:32 PM

History

#1 Updated by Tobias Ellinghaus 3 months ago

That looks like tiling discontinuities.

#2 Updated by Heiko Bauke 2 months ago

Peter M wrote:

something strange happens while using haze removal. These are two settings of strength: 0.96 and 0.59. I get horizontal and vertical lines that are becoming visible with strength above 0.20 What is really strange that vertical line changes it position depending on strength. Samples are just most visible part cut from whole photo. If needed, I can upload original RAW with xmp.

Similar artifacts have been reported before but I was not able to reproduce them. Can you please provide the RAW file and the xmp file such that I can investigate the issue. It might also be useful to know if the the attached png samples are parts of screen shots of the darkroom or of exported exported images.

#3 Updated by Peter M 2 months ago

Above are screen captures taken on dt ver 2.4.1 . Below attached are original RAW + xmp and another screen shot with photo viewer of exported jpg over darktable with RAW. Same effect in same places of the photo appear in version 2.4.2+dirty

#4 Updated by Heiko Bauke about 2 months ago

Peter M wrote:

Above are screen captures taken on dt ver 2.4.1 . Below attached are original RAW + xmp and another screen shot with photo viewer of exported jpg over darktable with RAW. Same effect in same places of the photo appear in version 2.4.2+dirty

Thanks for providing the RAW file. Now I was able to reproduce the reported bug. It has been fixed by the pull request 1682.

Also available in: Atom PDF