Project

General

Profile

Bug #11990

PW storage libsecret not found with version 2.5.0*

Added by Christophe Latt 5 months ago. Updated 5 months ago.

Status:
New
Priority:
Low
Assignee:
-
Category:
Lighttable
Start date:
02/01/2018
Due date:
% Done:

0%

Affected Version:
git master branch
System:
Ubuntu
bitness:
64-bit
hardware architecture:
amd64/x86

Description

Hello,
i have the problem that my google+ connection will not be saved with libsecret but with the developer version i have following messages:

[pwstorage_new] Creating new context 0x558a3258c160
[pwstorage_new] no storage backend. not storing username/password. please change in preferences, core tab.
[pwstorage_get] no backend. not reading anything.
[pwstorage_get] no backend. not reading anything.
[pwstorage_new] Destroying context 0x558a3258c160

There is no possibility to select libserver in preferences, there are only 'auto', 'kwallet' or 'none'.
In version 2.4.1 i see 'libserver' and after select them the start messages in console are:

[pwstorage_new] Creating new context 0x555ebd9c82a0
[pwstorage_new] using libsecret backend for username/password storage[pwstorage_new] Destroying context 0x555ebd9c82a0

But the connection is not stored anywhere and after darktable restart there is only 'new connection' as item to select.

with version 2.4.1 a

History

#1 Updated by Tobias Ellinghaus 5 months ago

I assume you are compiling darktable yourself? Please clean build/, re-run cmake and show its output. I guess that libsecret (not libserver!) isn't found.
About it not really storing anything across sessions is probably a problem in how it's set up on your system. I have to admit that I don't understand libsecret at all, there seems to be no useful documentation and no way to configure it. At least I couldn't find anything the last time I looked for it.

#2 Updated by Christophe Latt 5 months ago

Yes, you are right! I have effectively forget to install the header package from libsecret, therefore the master branche was not compiled with the library.Thank you for your quick answer and solution.
This problem is now resolved but the other problem is that the connection, with stable version 2.4.1 or the master branch version 2.5.0-rc*, is not stored anywhere and unfortunately documentation about libsecret is virtually zero.
Each new session, or after logout from google+ session, i must perform each step to create a new connection with google photo and i don't see any console output to let me see the cause of my problem, there is no item to select with connection data from previous session.

#3 Updated by Tobias Ellinghaus 5 months ago

Great, so the first problem is solved. I spent a good hour yesterday to look into the current state of libsecret. My conclusion is that not much has changed. The only backend libsecret can use to store credentials in is gnome-keyring. KWallet is still not able to be used. So, you either have to install gnome-keyring. Or, if you prefer to have the password in KWallet later, you have to select kwallet in darktable's preferences, and ignore libsecret.

Also available in: Atom PDF