Project

General

Profile

Bug #11981

Wrong default value for background threads on Windows

Added by Trond Olsen 9 months ago. Updated 6 months ago.

Status:
Fixed
Priority:
Low
Assignee:
-
Category:
Darkroom
Target version:
Start date:
01/30/2018
Due date:
% Done:

100%

Affected Version:
2.4.1
System:
Windows
bitness:
64-bit
hardware architecture:
amd64/x86

Description

On my system setup darktable is configured to 'background threads' to 1 after install. I experience very poor performance when handling thumbnails in folder with 1000+ images (from spinning harddrive). The interface can become unresponsive - especially if exiting the application. Changing 'background threads' to a higher number gives much smoother handling of thumbnails.

The user manual https://www.darktable.org/usermanual/en/core_options.html says:
NUMBER OF BACKGROUND THREADS
This controls how many parallel threads are used to create thumbnails during import. On 32bit systems it is strongly recommended to set this to 1. Needs a restart if changed (default 2).

History

#1 Updated by Trond Olsen 9 months ago

Title should refect Windows 64-bit.

#2 Updated by Peter Budai 9 months ago

Confirmed, the defaults are wrong on Windows. Actually I have found the reason and a fix will be created. Thanks for reporting.

#3 Updated by Trond Olsen 9 months ago

Great! Thanks also for quickly fixing things.

#4 Updated by Peter Budai 8 months ago

#5 Updated by Tobias Ellinghaus 8 months ago

  • Status changed from New to Fixed
  • % Done changed from 0 to 100

#6 Updated by Roman Lebedev 6 months ago

  • Target version set to 2.6.0

Also available in: Atom PDF