Project

General

Profile

Bug #11972

Windows 10 - Export adds extra backslashes to path

Added by Stuart B almost 2 years ago. Updated almost 2 years ago.

Status:
Closed: invalid
Priority:
Low
Assignee:
-
Category:
Lighttable
Target version:
Start date:
01/28/2018
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.4.0
System:
Windows
bitness:
64-bit
hardware architecture:
amd64/x86

Description

I've been working on some RAW images in darktable 2.4.0 on Windows 10 the images were stored in C:\\Users\Stuart\Pictures\Spotting Pics\2018\2018-01-26 MAN , I wanted to save them export them to C:\\Users\Stuart\Pictures\Spotting Pics\2018\2018-01-26 MAN\mancavgeek\ , unfortunately, the program doubles all the backslashes, then failed silently, nothing was actually saved, and it took a while to figure out it was bewcause it was trying to send them to C:\\\\Users\\Stuart\\Pictures\\Spotting Pics\\2018\\2018-01-26 MAN\\mancavgeek\\$(FILE_NAME).
Updated to 2.4.1 and tried again, this time the export actually worked, even though it was now trying to send to C:\\Users\\Stuart\\Pictures\\Spotting Pics\\2018\\2018-01-26 MAN\\mancavgeek\\$(FILE_NAME).
Oddly, the initial double backslash after the c: is now correct, it's just the rest.
It's not an earth-shattering problem, as it is possible to manually alter the path, but it was confusing the first time it happened.

StuartB

History

#1 Updated by Tobias Ellinghaus almost 2 years ago

  • Status changed from New to Closed: invalid

All is fine, the double \ are supposed to be there. A single \ is used for escaping in variables expansion.

#2 Updated by Roman Lebedev almost 2 years ago

  • Target version set to 2.6.0

Also available in: Atom PDF

Go to top