Project

General

Profile

Bug #11967

TIF export error

Added by Pavel Konter over 1 year ago. Updated over 1 year ago.

Status:
Duplicate
Priority:
Low
Assignee:
-
Category:
Lighttable
Target version:
Start date:
01/24/2018
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.4.1
System:
Windows
bitness:
64-bit
hardware architecture:
amd64/x86

Description

I can't export TIF with target storage "file on disk". Always I've get message "could not export to file ..." (darktable1.jpg).

But if I change target storage to "send as mail", darktable export TIF properly (darktable2.jpg). But then I cannnot set destination folder. Always TIF is exported to "..\AppData\Local\Temp" and I have to manually copy it.

I've tried export with target storage "file on disk" to many folders, even "..\AppData\Local\Temp", but always get error message. It's not a problem with folder permissions.

Scans are from 2.4.0, but 2.4.1 it's the same.

darktable2.jpg (468 KB) darktable2.jpg Pavel Konter, 01/24/2018 11:19 PM
darktable1.jpg (480 KB) darktable1.jpg Pavel Konter, 01/24/2018 11:19 PM

Related issues

Is duplicate of darktable - Bug #11873: Unable to export as uncompressed 16 bit TIFF from an Adobe RGB Canon RAW image on Windows 10Closed: invalid12/21/2017

Associated revisions

Revision dbccb8c2 (diff)
Added by Tobias Ellinghaus over 1 year ago

Windows Fix TIFF with non-ASCII filenames

This should fix both reading and writing those files. I wished that
TIFFOpenW was mentioned in any documentation.

Fixes #11967
Fixes #11873

Revision f0ae62e7 (diff)
Added by Tobias Ellinghaus over 1 year ago

Windows Fix TIFF with non-ASCII filenames

This should fix both reading and writing those files. I wished that
TIFFOpenW was mentioned in any documentation.

Fixes #11967
Fixes #11873

(cherry picked from commit dbccb8c2e69b4ba39d267b0b1fd5d910f08476c9)

History

#1 Updated by Roman Lebedev over 1 year ago

  • Is duplicate of Bug #11873: Unable to export as uncompressed 16 bit TIFF from an Adobe RGB Canon RAW image on Windows 10 added

#2 Updated by Tobias Ellinghaus over 1 year ago

Does your username contain any special chars? Maybe try exporting directly to C:\ – does that work?

#3 Updated by Pavel Konter over 1 year ago

Yes, it's work. I have polish letters in my username.

#4 Updated by Tobias Ellinghaus over 1 year ago

  • Status changed from New to Duplicate

As expected (and hinted to by Roman), the problem is that libtiff is broken. We'll see if we can somehow work around that.

#5 Updated by Roman Lebedev over 1 year ago

  • Target version set to 2.6.0

Also available in: Atom PDF

Go to top