Project

General

Profile

Feature #11925

Integrate new cameras as minor releases ASAP

Added by Assurancetourix Le Barde 8 months ago. Updated 8 months ago.

Status:
Closed: invalid
Priority:
Low
Assignee:
-
Category:
General
Target version:
Start date:
01/12/2018
Due date:
% Done:

0%

Affected Version:
git master branch
System:
all
bitness:
64-bit
hardware architecture:
amd64/x86

Description

Hello,
I would like to suggest to generally release support for new cameras as soon as possible, for example in bugfix releases.
If I take the example of the mainstream Panasonic GH5, the issue (https://redmine.darktable.org/issues/11565) was first filed on 06/04/2017, solved on 18/04/2017 (so nice!) made visible in the open world only on 24/12/2017 (https://redmine.darktable.org/issues/11565).

This is an issue for non-tech people because most of them won't be able to use Darktable with their favourite photo software.

In my situation I just purchased a Panasonic DC-G9. I can't use it with my current Debian version (which is 2.2.1 on debian stable), neither by installing a last official version, but I still can get master and build it.

What are your thoughts about this? Thank you by advance!

History

#1 Updated by Roman Lebedev 8 months ago

  • Status changed from New to Closed: invalid

Assurancetourix Le Barde wrote:

Hello,

If I take the example of the mainstream Panasonic GH5, the issue (https://redmine.darktable.org/issues/11565) was first filed on 06/04/2017, solved on 18/04/2017 (so nice!) made visible in the open world only on 24/12/2017 (https://redmine.darktable.org/issues/11565).

That is not true, Panasonic GH5 support was in 2.2.5 release already: https://github.com/darktable-org/darktable/releases/tag/release-2.2.5
2.2.5 was released on May 28, 2017

I would like to suggest to generally release support for new cameras as soon as possible, for example in bugfix releases.

That is what we do already.

This is an issue for non-tech people because most of them won't be able to use Darktable with their favourite photo software.

In my situation I just purchased a Panasonic DC-G9.
I can't use it with my current Debian version (which is 2.2.1 on debian stable)

2.2.1 is about one year old.
Panasonic DC-G9 was announced Nov 8, 2017, about two months ago https://www.dpreview.com/products/panasonic/slrs/panasonic_dcg9
How a program released well before the camera could possibly support the camera released a while after the release of the program?

We had no minor releases since 2.2.5, and not having the stable branch person does not help that at all.

neither by installing a last official version, but I still can get master and build it.

The support was added in #11886, after 2.4.0 release, and will be present in 2.4.1 release, should it happen.

What are your thoughts about this? Thank you by advance!

#2 Updated by Assurancetourix Le Barde 8 months ago

Thank you for your answer!

I did not want to be offending and if some of my words went brutal, I would like to apologise. Actually this is a good news about GH5, I only looked on the roadmaps towards what version the issue was attributed to. So, that's so good!

In my message I did not mean to add the support before that could be possible. Actually I meant that if there is no bugfix release for a long time the support for those cameras could be released much after that.

The support was added in #11886, after 2.4.0 release, and will be present in 2.4.1 release, should it happen.

This is what I meant: regularly creating bugfixes to add support for the new cameras (one every one or two months for people who really need them).

#3 Updated by Roman Lebedev 8 months ago

  • Target version set to 2.6.0

Also available in: Atom PDF