Project

General

Profile

Bug #11884

Slow TIFF export

Added by Peter Budai 10 months ago. Updated 9 months ago.

Status:
Closed: upstream
Priority:
Low
Assignee:
-
Category:
Lighttable
Target version:
Start date:
12/27/2017
Due date:
% Done:

0%

Affected Version:
git master branch
System:
Windows
bitness:
64-bit
hardware architecture:
amd64/x86

Description

This is just to prevent further bug reports on the same subject:
TIFF export is extremely slow under certain circumstances.

Problem seems to be related upstream exiv2, which has been reported here:
https://github.com/Exiv2/exiv2/issues/200

We should keep this open until upstream fixes this.

History

#1 Updated by Peter Budai 9 months ago

Update: the root cause has been identified and a patch has been created and tested. After it will be merged to mingw-w64-exiv2 package, subsequent builds and installs should not show this symptom anymore.

#2 Updated by Peter Budai 9 months ago

The patched exiv2 is now available in the MSYS2 repo. We can close this case. (Though would be great to have somebody else also testing)

#3 Updated by Tobias Ellinghaus 9 months ago

  • Status changed from New to Closed: upstream

Fix confirmed. TIFF export is still slower than JPEG, but not as bad as it used to be (JPEG: 3sec, TIFF before: 1min, now: 9sec).

#4 Updated by Roman Lebedev 9 months ago

  • Target version set to 2.6.0

Also available in: Atom PDF