Project

General

Profile

Camera Support #11875

Lens Correction module recognizes lens, not camera

Added by Bob Tregilus 10 months ago. Updated 10 months ago.

Status:
Closed: upstream
Priority:
Low
Assignee:
-
Category:
Darkroom
Target version:
Start date:
12/23/2017
Due date:
% Done:

0%

Affected Version:
2.4.0rc2

Description

Darktable recognizing lens but not the camera.

I installed Pascal's Darktable Unstable PPA version 2.4.0~rc2 which also installed Lensfun 2.8-3.

2.4.0~rc2 recognizes the new Sony ILCE-7RM3 fine (Ref. Camera Support #11848).

Both the Sony FE 55mm f/1.8 (SEL55F18Z) and the Sony FE 16-35mm f/4 (SEL1635Z) have been in the lensfun database for sometime now and are recognize along with the first version of the a7r series (ILCE7R) with no problem in 2.4.0~rc2.

But while DT recognizes both of the lenses, it's not matching them up in the Lens Correction module with the ILCE-7RM3.

Additionally, the ILCE-7RM3 does not appear in the camera selector within the lens correction module. However, the ILCE7R (a7r) and the ILCE7RM2 (a7rII) are both listed in the camera selector.

Perhaps the ILCE-7RM3 needs to be added to the lens correction module?

Below is the output from:
~ $ exiv2 -pt DSC00154.ARW

Exif.Image.NewSubfileType Long 1 Thumbnail/Preview image
Exif.Image.Compression Short 1 JPEG (old-style)
Exif.Image.ImageDescription Ascii 32
Exif.Image.Make Ascii 5 SONY
Exif.Image.Model Ascii 10 ILCE-7RM3
Exif.Image.Orientation Short 1 top, left
Exif.Image.XResolution Rational 1 350
Exif.Image.YResolution Rational 1 350
Exif.Image.ResolutionUnit Short 1 inch
Exif.Image.Software Ascii 16 ILCE-7RM3 v1.00
Exif.Image.DateTime Ascii 20 2017:12:21 19:56:35
Exif.Image.Artist Ascii 13 Bob Tregilus
Exif.Image.SubIFDs Long 1 144996
Exif.SubImage1.NewSubfileType Long 1 Primary image
Exif.SubImage1.ImageWidth Short 1 8000
Exif.SubImage1.ImageLength Short 1 5320
Exif.SubImage1.BitsPerSample Short 1 12
Exif.SubImage1.Compression Short 1 Uncompressed
Exif.SubImage1.PhotometricInterpretation Short 1 Color Filter Array
Exif.SubImage1.SamplesPerPixel Short 1 1
Exif.SubImage1.PlanarConfiguration Short 1 1
Exif.SubImage1.XResolution Rational 1 350
Exif.SubImage1.YResolution Rational 1 350
Exif.SubImage1.ResolutionUnit Short 1 inch
Exif.SubImage1.CFARepeatPatternDim Short 2 2 2
Exif.SubImage1.CFAPattern Byte 4 0 1 1 2
Exif.SubImage1.StripOffsets Long 1 647168
Exif.SubImage1.RowsPerStrip Short 1 5320
Exif.SubImage1.StripByteCounts Long 1 85120000
Exif.SubImage1.WhiteLevel Short 1 16380
Exif.SubImage1.DefaultCropOrigin Long 2 8 8
Exif.SubImage1.DefaultCropSize Long 2 7952 5304
Exif.Image.JPEGInterchangeFormat Long 1 147618
Exif.Image.JPEGInterchangeFormatLength Long 1 496272
Exif.Image.YCbCrPositioning Short 1 Co-sited
Exif.Image.XMLPacket Byte 4096 (Binary value suppressed)
Exif.Image.Copyright Ascii 41 CC BY-NC-SA 4.0 Bob Tregilus Photography
Exif.Image.ExifTag Long 1 4624
Exif.Photo.ExposureTime Rational 1 3 s
Exif.Photo.FNumber Rational 1 F11
Exif.Photo.ExposureProgram Short 1 Manual
Exif.Photo.ISOSpeedRatings Short 1 100
Exif.Photo.SensitivityType Short 1 2
Exif.Photo.RecommendedExposureIndex Long 1 100
Exif.Photo.ExifVersion Undefined 4 2.31
Exif.Photo.DateTimeOriginal Ascii 20 2017:12:21 19:56:35
Exif.Photo.DateTimeDigitized Ascii 20 2017:12:21 19:56:35
Exif.Photo.ComponentsConfiguration Undefined 4 YCbCr
Exif.Photo.CompressedBitsPerPixel Rational 1 6
Exif.Photo.BrightnessValue SRational 1 -3.33047
Exif.Photo.ExposureBiasValue SRational 1 0 EV
Exif.Photo.MaxApertureValue Rational 1 F4
Exif.Photo.MeteringMode Short 1 Multi-segment
Exif.Photo.LightSource Short 1 Shade
Exif.Photo.Flash Short 1 No, compulsory
Exif.Photo.FocalLength Rational 1 24.0 mm
Exif.Photo.MakerNote Undefined 37496 (Binary value suppressed)
Exif.MakerNote.Offset Long 1 5254
Exif.MakerNote.ByteOrder Ascii 3 II
Exif.Sony2.Panorama Long 16 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
Exif.Sony2.Contrast SLong 1 0
Exif.Sony2.Saturation SLong 1 0
Exif.Sony2.AutoHDR Long 1 Off
Exif.Sony2.ShotInfo Undefined 390 (Binary value suppressed)
Exif.Sony2.ColorReproduction Ascii 16 Neutral
Exif.Sony2.ColorTemperature Long 1 0
Exif.Sony2.ColorCompensationFilter Long 1 0
Exif.Sony2.SceneMode Long 1 Standard
Exif.Sony2.ZoneMatching Long 1 ISO Setting Used
Exif.Sony2.DynamicRangeOptimizer Long 1 Off
Exif.Sony2.ImageStabilization Long 1 Off
Exif.Sony2.ColorMode Long 1 Neutral
Exif.Sony2.FullImageSize Long 2 5304 x 7952
Exif.Sony2.PreviewImageSize Long 2 1080 x 1616
Exif.Sony2.FileFormat Byte 4 (3 3 3 0)
Exif.Sony2.Quality Long 1 Raw
Exif.Sony2.FlashExposureComp SRational 1 0 EV
Exif.Sony2.WhiteBalanceFineTune Long 1 0
Exif.Sony2.WhiteBalance Long 1 Shade
Exif.Sony2.SonyModelID Short 1 (362)
Exif.Sony2.LensID Long 1 Manual lens
Exif.Sony2.ExposureMode Short 1 Manual
Exif.Sony2.FlashLevel SShort 1 Normal
Exif.Sony2.ReleaseMode Short 1 Normal
Exif.Sony2.SequenceNumber Short 1 Single
Exif.Sony2.AntiBlur Short 1 Off
Exif.Sony2.DynamicRangeOptimizer Short 1 Off
Exif.Sony2.IntelligentAuto Short 1 Off
Exif.Sony2.WhiteBalance2 Short 1 Auto
Exif.Photo.UserComment Undefined 64
Exif.Photo.FlashpixVersion Undefined 4 1.00
Exif.Photo.ColorSpace Short 1 sRGB
Exif.Photo.PixelXDimension Long 1 7952
Exif.Photo.PixelYDimension Long 1 5304
Exif.Photo.InteroperabilityTag Long 1 42876
Exif.Iop.InteroperabilityIndex Ascii 4 R98
Exif.Iop.InteroperabilityVersion Undefined 4 1.00
Exif.Photo.FileSource Undefined 1 Digital still camera
Exif.Photo.SceneType Undefined 1 Directly photographed
Exif.Photo.CustomRendered Short 1 Normal process
Exif.Photo.ExposureMode Short 1 Manual
Exif.Photo.WhiteBalance Short 1 Manual
Exif.Photo.DigitalZoomRatio Rational 1 1.0
Exif.Photo.FocalLengthIn35mmFilm Short 1 24.0 mm
Exif.Photo.SceneCaptureType Short 1 Standard
Exif.Photo.Contrast Short 1 Normal
Exif.Photo.Saturation Short 1 Normal
Exif.Photo.Sharpness Short 1 Normal
Exif.Photo.LensSpecification Rational 4 160/10 350/10 40/10 40/10
Exif.Photo.LensModel Ascii 21 FE 16-35mm F4 ZA OSS
Exif.Image.PrintImageMatching Undefined 106 80 114 105 110 116 73 77 0 48 51 48 48 0 0 3 0 2 0 1 0 0 0 3 0 34 0 0 0 1 1 0 0 0 0 9 17 0 0 16 39 0 0 11 15 0 0 16 39 0 0 151 5 0 0 16 39 0 0 176 8 0 0 16 39 0 0 1 28 0 0 16 39 0 0 94 2 0 0 16 39 0 0 139 0 0 0 16 39 0 0 203 3 0 0 16 39 0 0 229 27 0 0 16 39 0 0
Exif.Image.DNGPrivateData Byte 4 110 199 0 0
Exif.Thumbnail.NewSubfileType Long 1 Thumbnail/Preview image
Exif.Thumbnail.Compression Short 1 JPEG (old-style)
Exif.Thumbnail.ImageDescription Ascii 32
Exif.Thumbnail.Make Ascii 5 SONY
Exif.Thumbnail.Model Ascii 10 ILCE-7RM3
Exif.Thumbnail.Orientation Short 1 top, left
Exif.Thumbnail.XResolution Rational 1 72
Exif.Thumbnail.YResolution Rational 1 72
Exif.Thumbnail.ResolutionUnit Short 1 inch
Exif.Thumbnail.Software Ascii 16 ILCE-7RM3 v1.00
Exif.Thumbnail.DateTime Ascii 20 2017:12:21 19:56:35
Exif.Thumbnail.Artist Ascii 13 Bob Tregilus
Exif.Thumbnail.JPEGInterchangeFormat Long 1 43260
Exif.Thumbnail.JPEGInterchangeFormatLength Long 1 6446
Exif.Thumbnail.YCbCrPositioning Short 1 Co-sited

Thanks!

Bob

Sony_ILCE-7RM3.xml Magnifier (241 Bytes) Bob Tregilus, 12/30/2017 04:06 AM

History

#1 Updated by Roman Lebedev 10 months ago

  • Status changed from New to Closed: upstream

That is lensfun issue.

#2 Updated by Roman Lebedev 10 months ago

  • Target version changed from 2.4.0 to 2.6.0

#3 Updated by Bob Tregilus 10 months ago

When you marked this upstream / Lensfun, Roman, I went and looked around and figured out that I needed to create a simple .xml file and add to </usr/share/lensfun/mil-sony.xml> on my machine.

Since doing so, the DT lens correction module now correctly identifies both my camera and my lens (most of them anyway, need to profile my 150-600 Tamron one of these days, yet).

I opened a Lensfun feature support ticket (#110) <https://sourceforge.net/p/lensfun/features/110/> to add support for the Sony ILCE-7RM3 and attached the .xml file I created to the ticket (also attached here).

I have a question regading the "cropfactor", however. In the instructions for creating the .xml file Bronger writes, "Be accurate."

Therefore, d = sqrt((35.9^2 + 24.0^2)mm) = 43.1834

Then Bronger says to divide the divisor by 43.27 "the diagonal of a usual 35mm film frame," therefore, 43.27 / 43.184 = 1.002.

So do you know if the cropfactor should be "1" or the calculated "1.002"?

I used 1.002 in the .xml file.

Thanks! (And I'm really enjoying DT 2.4.0! Congratulations on a great new DT release!)

#4 Updated by Roman Lebedev 10 months ago

Bob Tregilus wrote:

When you marked this upstream / Lensfun, Roman, I went and looked around and figured out that I needed to create a simple .xml file and add to </usr/share/lensfun/mil-sony.xml> on my machine.

Since doing so, the DT lens correction module now correctly identifies both my camera and my lens (most of them anyway, need to profile my 150-600 Tamron one of these days, yet).

I opened a Lensfun feature support ticket (#110) <https://sourceforge.net/p/lensfun/features/110/> to add support for the Sony ILCE-7RM3 and attached the .xml file I created to the ticket (also attached here).

I have a question regading the "cropfactor", however. In the instructions for creating the .xml file Bronger writes, "Be accurate."

Therefore, d = sqrt((35.9^2 + 24.0^2)mm) = 43.1834

Then Bronger says to divide the divisor by 43.27 "the diagonal of a usual 35mm film frame," therefore, 43.27 / 43.184 = 1.002.

So do you know if the cropfactor should be "1" or the calculated "1.002"?

I used 1.002 in the .xml file.

Assuming the https://www.sony.com/electronics/interchangeable-lens-cameras/ilce-7rm3/specifications is truthful and correct,
https://www.wolframalpha.com/input/?i=sqrt(36%5E2+%2B+24%5E2)+%2F+sqrt((35.9)%5E2+%2B+24%5E2)
1.001925955687272722993367519767033427884832075291657945791...

Don't know how many digits you should specify.

Thanks! (And I'm really enjoying DT 2.4.0! Congratulations on a great new DT release!)

Also available in: Atom PDF