Project

General

Profile

Bug #11871

Can't export a photo, Darktable is crashing instantly

Added by François Tissandier over 1 year ago. Updated over 1 year ago.

Status:
Closed: invalid
Priority:
Low
Assignee:
-
Category:
General
Target version:
Start date:
12/20/2017
Due date:
% Done:

0%

Affected Version:
2.4.0rc2
System:
unknown
bitness:
64-bit
hardware architecture:
amd64/x86

Description

I'm trying the new 2.4 version on a VM on Ubuntu.
Version 2.4.0rc2, on an Ubuntu 17.10 system, run in QEMU

When i'm trying to export, in JPEG or TIFF, it's working, then crashing. I see only "Killed" in the terminal.
The same RAW & XMP is exporting fine in version 2.2.5

Is Darktable supposed to work in a VM ?

Since the RAW is too big to be included here, here is a link to the raw, the xmp, and the jpg exported from DT2.2.5 :

https://drive.google.com/open?id=1xU2h1f9nzoMxBl06AN3CTGarFIIT15Kx

empty_dt.sh Magnifier - the script that to replace all scripts (251 Bytes) Roman Lebedev, 12/21/2017 11:55 AM

History

#1 Updated by Roman Lebedev over 1 year ago

  • System changed from Ubuntu to unknown

François Tissandier wrote:

I'm trying the new 2.4 version on a VM on Ubuntu.
Version 2.4.0rc2, on an Ubuntu 17.10 system, run in QEMU

When i'm trying to export, in JPEG or TIFF, it's working, then crashing. I see only "Killed" in the terminal.
The same RAW & XMP is exporting fine in version 2.2.5

Is Darktable supposed to work in a VM ?

Things you did not specify:
  • Why VM?
  • How much ram (this is most likely the problem)
  • Is the VM 32-bit?

#2 Updated by François Tissandier over 1 year ago

  • Why VM?
  • How much ram (this is most likely the problem)
  • Is the VM 32-bit?

*I use a VM to avoid touching the config folder of my DT. I don't have a spare machine to do my tests, and I want to be careful. Is there a way to use a compiled version with a specific config folder ? I guess I have to run it with specific arguements in the command line, right ? The VM was an easy to do it though...

*Indeed, 2GB was not enough, especially with an A7RII photo. With 3GB I was able to export the photo.
*64 bits all the way

Thank you for your answer, I should have thought about that !

#3 Updated by Roman Lebedev over 1 year ago

  • Status changed from New to Closed: invalid
  • File empty_dt.shMagnifier added

François Tissandier wrote:

  • Why VM?
  • How much ram (this is most likely the problem)
  • Is the VM 32-bit?

*I use a VM to avoid touching the config folder of my DT. I don't have a spare machine to do my tests, and I want to be careful. Is there a way to use a compiled version with a specific config folder ? I guess I have to run it with specific arguements in the command line, right ? The VM was an easy to do it though...

See attached script.

*Indeed, 2GB was not enough, especially with an A7RII photo. With 3GB I was able to export the photo.

That is still tiny.
If less than 4Gb, the problems are pretty much guaranteed.

*64 bits all the way

Thank you for your answer, I should have thought about that !

#4 Updated by François Tissandier over 1 year ago

perfect, thanks, I will use this script to test the RC more !

Also available in: Atom PDF