Project

General

Profile

Bug #11868

Failed to read camera white balance information while opening raw file produced by Fuji X-T20

Added by Dmitry Pisklov over 1 year ago. Updated over 1 year ago.

Status:
Fixed
Priority:
Low
Assignee:
Category:
Darkroom
Target version:
Start date:
12/18/2017
Due date:
% Done:

100%

Affected Version:
2.4.0rc2
System:
other GNU/Linux
bitness:
64-bit
hardware architecture:
amd64/x86

Description

I've got Fuji X-T20 and I use compressed RAW format. It doesn't work with DT 2.2.x so I use git version (provided in AUR - darktable-git-release.2.4.0rc2.r11.g405023242), and until today it worked on all my pictures, but today I imported a folder, and of 30 images, DT refused to open 2, both times showing "working..." and on top "Failed to read camera white balance information". Preview is displayed correctly. One of the problematic files attached.

DSCF0729.RAF (32.1 MB) Dmitry Pisklov, 12/18/2017 07:58 PM

Associated revisions

Revision d82c0e52
Added by Roman Lebedev over 1 year ago

RawSpeed submodule update: fuzzing, compressed RAF detection fix.

Fixes #11868

History

#1 Updated by Roman Lebedev over 1 year ago

So is that compressed raw or uncompressed?

#2 Updated by Roman Lebedev over 1 year ago

  • % Done changed from 0 to 20
  • Assignee set to Roman Lebedev
  • Status changed from New to Triaged

It is compressed.

#3 Updated by Roman Lebedev over 1 year ago

  • % Done changed from 20 to 100
  • Status changed from Triaged to Fixed

#4 Updated by Dmitry Pisklov over 1 year ago

Works now - thanks!

#5 Updated by Roman Lebedev over 1 year ago

  • Target version set to 2.4.0

Also available in: Atom PDF