Project

General

Profile

Bug #11855

In the Exposure module, the "mode" dropdown is missing

Added by Michael Berg over 1 year ago. Updated over 1 year ago.

Status:
Closed: invalid
Priority:
Low
Assignee:
-
Category:
Darkroom
Target version:
Start date:
12/14/2017
Due date:
% Done:

0%

Affected Version:
2.4.0rc0
System:
Ubuntu
bitness:
64-bit
hardware architecture:
amd64/x86

Description

I have a strange issue that I have not been able to find any clues to so far.

Simply put, the Exposure module settings should have a "Mode" dropdown containing a Manual and an Automatic setting. And indeed on another computer this mode dropdown is there, and it works just fine.

But on my main computer the mode dropdown simply is not there. I'll attach a screenshot to show you what it looks like.

Is there some reason for this? Is there something I can do to bring out this Mode dropdown?

I've tried 2.2.5 as well as the new 2.4.0.RC0 release. No Mode dropdown in any of them. Perhaps I should also mention that I am editing DNG files if this makes a difference.

darktable_001.png - Showing where I expect the Mode dropdown to be (489 KB) Michael Berg, 12/14/2017 01:06 AM

Associated revisions

Revision 7d82a2d7
Added by Tobias Ellinghaus over 1 year ago

exposure: Don't hide mode, just disable it

When using exposure on anything but raw files we don't support automatic
mode. Before the iop hid the combobox, confusing users. With this commit
we make it insensitive instead so people understand that they can't
change it while still seeing in what mode they are.

Related to bug #11855.

History

#1 Updated by Tobias Ellinghaus over 1 year ago

  • Affected Version changed from 2.2.5 to 2.4.0rc0
  • Target version set to 2.4.0

The mode is only shown for raw files. For some reason you DNG isn't seen as such. Please attach it to this bug report so we can have a look.

#2 Updated by Roman Lebedev over 1 year ago

  • % Done changed from 0 to 20
  • Status changed from New to Incomplete

Michael Berg wrote:
Was it there for these dng, ever?
If yes, then it is one again rawspeed regression.
If not, i guess these are float dng's, it is only there for uint16-ones IIRC
Anyway, like houz said, please share that dng.

#3 Updated by Michael Berg over 1 year ago

It was a bit hard to squeeze under the 48 mb upload limit but here you go :-)

The thing about these DNG files is that they were created with Iridient X-Transformer (1.0 beta 4, the latest version available).

THe original file was a "RAF" compressed Fuji raw file from a Fuji X-T2.

Thanks for taking the time to investigate this - hope the attachment helps.

#4 Updated by Roman Lebedev over 1 year ago

Michael Berg wrote:

It was a bit hard to squeeze under the 48 mb upload limit but here you go :-)

No attachment happened.

THe original file was a "RAF" compressed Fuji raw file from a Fuji X-T2.

That is natively supported in 2.4.0rc0, don't convert to dng.

The thing about these DNG files is that they were created with Iridient X-Transformer (1.0 beta 4, the latest version available).

Yeah, don't convert to dng, creates all kinds of problems.

Thanks for taking the time to investigate this - hope the attachment helps.

#5 Updated by Michael Berg over 1 year ago

Trying again to attach the DNG file. If it succeeds, would you mind taking a look at it and perhaps check what makes Darktable think this is not a raw file?

I understand that 2.4.0 supports compressed RAF files but Darktable didn't do this until just a few days ago. So I haven't had time to adjust my workflow yet, or evaluate how well it converts the RAF files. Like many Fuji users I really like the Iridient results. I'm not sure what other problems you are referring to with respect to DNG files, Darktable has handled everything else about them just nicely :-)

#6 Updated by Michael Berg over 1 year ago

I don't know why the upload isn't working. Here's a shared link to the file on my DropBox:

https://www.dropbox.com/s/jq24t7pl63fdjki/DSCF3381.dng.bz2?dl=0

#7 Updated by Roman Lebedev over 1 year ago

  • Status changed from Incomplete to Closed: invalid
  • % Done changed from 20 to 0

Michael Berg wrote:

I don't know why the upload isn't working. Here's a shared link to the file on my DropBox:

https://www.dropbox.com/s/jq24t7pl63fdjki/DSCF3381.dng.bz2?dl=0

That is not even a raw file anymore. It's already demosaiced. And the data is (not surprisingly) stored in floats:

The mode=automatic in exposure module only supports the uint16 inputs.

So i'm gonna just close this i'm afraid :(

#8 Updated by Roman Lebedev over 1 year ago

Ok, i have to correct my last comment.
1. yes, it is demosaiced
2. no, it is not float, still uint16
3. but it is 3 channels (naturally, since it is demosaiced.)
4. and deflicker does not like all that.

So i think the state remains.

#9 Updated by Michael Berg over 1 year ago

So the problem is that auto exposure only works for certain types of input files - If I understand you correctly?

I think it would be a very useful improvement if the exposure module was able to make automatic adjustments regardless of the original file format - like the Levels module. If there a way for me to formally suggest such a feature for inclusion in a future version of Darktable?

Also I would suggest that the documentation at least mentions this current limitation of the exposure module:

https://www.darktable.org/usermanual/ch03s04.html.php

If there is any way I can contribute with respect to this problem or the documentation I'd be happy to do so.

#10 Updated by Roman Lebedev over 1 year ago

Michael Berg wrote:

So the problem is that auto exposure only works for certain types of input files - If I understand you correctly?

Yes, basically.

I think it would be a very useful improvement if the exposure module was able to make automatic adjustments regardless of the original file format - like the Levels

module. If there a way for me to formally suggest such a feature for inclusion in a future version of Darktable?

No, that won't work. Not counting the three channels (and what to do with that? just count as one channel? take min/max?), it depends on the raw image's black/white levels, and if the image is not raw (1ch uint16 mosaic), then those are not really true. And in case of non-uint16-bit inputs (so anything else basically) you will additionally have the problem of taking histogram of float data...
So quite unfeasible.

Also I would suggest that the documentation at least mentions this current limitation of the exposure module:

https://www.darktable.org/usermanual/ch03s04.html.php

"Automatic adjustment is only available for raw images."
So it is at the very least mentioned.

If there is any way I can contribute with respect to this problem or the documentation I'd be happy to do so.

Hmm, i'm not sure if "what does raw mean here" is documented in the usermanual. But not sure of how much help would that be.

#11 Updated by Michael Berg over 1 year ago

Hello Roman,

I understand that the Darktable exposure module is implemented in a way which apparently relies on the source image having a specific layout. But don't get stuck on implementation details like that and dismiss automatic exposure as "completely unfeasible". It is not unfeasible that a raw processor is able to do automatic exposure. Capture One does it, Rawtherapee does it, lightroom does it. Even on jpegs.

If the current design of the exposure module is unsuited to work on anything but 1 ch uint16 mosaic files then perhaps it should be replaced with a more flexible design that is able to address the needs of the user. I was asking for a formal way to suggest such a feature for inclusion in a future version of Darktable. It is possible to suggest features, is it not?

Taking a histogram of float data is possible, if you quantize the levels into some fixed range. This should be more than adequate to estimate an exposure range. Just multiply your float by 65536 to get your uint16. How's that for a start?

Working on three channels (r,g,b) in stead of just one (l) channel means it "won't work"? How about (r+g+b)/3 for an L estimate? Come on, this is not rocket science.

As the for the documentation, I think if you ask 99.99% of all users, they will classify a DNG as a raw file. It would not hurt if the documentation was more clear in this direction.

#12 Updated by Tobias Ellinghaus over 1 year ago

For non-raw files there is already the color picker button that does what you want. The mode limited to raw files is more sophisticated than just pushing the brightness till the histogram is filled.

About users expecting DNG files to be raw: It's beyond our capabilities to teach them that converting to DNG is in general a bad idea and that DNG is merely a container that can hold a bunch of different things. Raw data being one of them.

#13 Updated by Michael Berg over 1 year ago

Hello Tobias,

Thanks for the helpful response. I had played around with the dropper but I was not sure if this really was an automatic mode, since the documentation specifically mentions the Mode dropdown which was missing in my case. I wish I knew how these two types of automatic exposure differs though :-)

I'm wondering if the "dropper-method" can be copied and pasted to a whole bunch of images, or if the dropper just selects an EV and then it's just that specific EV that gets copied? I'm looking for a way to quickly auto-expose a bunch of imported images.

Regarding DNG I have no feelings either way. My DNG file did contain raw data although it was produced not by a camera but a third party application. It's difficult for an end user to tell the difference to be honest, nor why it makes a difference with respect to relatively simple things like automatic exposure. Especially because other modules like Levels for example, seem to have no problems performing automatic levelling.

Anyway, thanks for your repsonse.

#14 Updated by Tobias Ellinghaus over 1 year ago

Michael Berg wrote:

My DNG file did contain raw data

That's the point: it did NOT contain raw data! Your DNG is a regular raster image. So all the algorithms working on raw data can't be used.

Also available in: Atom PDF