Project

General

Profile

Camera Support #11852

Liblensfun0 use in darktable 2.4 Rc0

Added by Jean-Paul GAUCHE over 1 year ago. Updated over 1 year ago.

Status:
Closed: upstream
Priority:
Medium
Assignee:
-
Category:
-
Target version:
Start date:
12/11/2017
Due date:
% Done:

0%

Affected Version:
2.4.0rc0

Description

A friend has just installed the darktable version 2.4 Rc0 of Pascal de Bruijn’s ppa. He found that he still uses liblensfun0 (Lensfun 0.2.8-3) while liblensfun1 (Lensfun 0.3.2-3) has already been released with a greater definition of objectives. We also found that manual addition of lens definitions can cause problems with darktable. Pascal de Bruijn could you allow your ppa to use a newer version of Lensfun?

History

#1 Updated by Roman Lebedev over 1 year ago

  • Status changed from New to Closed: upstream

Jean-Paul GAUCHE wrote:

A friend has just installed the darktable version 2.4 Rc0 of Pascal de Bruijn’s ppa.

Report that bug to the PPA.

He found that he still uses liblensfun0 (Lensfun 0.2.8-3) while liblensfun1 (Lensfun 0.3.2-3) has already been released with a greater definition of objectives.

pmjdebruijn's lensfun is already updated with all the lens, IIRC.

We also found that manual addition of lens definitions can cause problems with darktable.

Report that to the lensfun upstream, with a bit more detail than here :)

Pascal de Bruijn could you allow your ppa to use a newer version of Lensfun?

lensfun 0.3 series has broke ABI but did not bump the soversion, so it is not safe to just upgrade the lensfun.
similarly, you wouldn't want to upgrade the whole library package from some ppa.

#2 Updated by Jean-Paul GAUCHE over 1 year ago

Roman Lebedev wrote:

Jean-Paul GAUCHE wrote:

A friend has just installed the darktable version 2.4 Rc0 of Pascal de Bruijn’s ppa.

Report that bug to the PPA.

He found that he still uses liblensfun0 (Lensfun 0.2.8-3) while liblensfun1 (Lensfun 0.3.2-3) has already been released with a greater definition of objectives.

pmjdebruijn's lensfun is already updated with all the lens, IIRC.

We also found that manual addition of lens definitions can cause problems with darktable.

Report that to the lensfun upstream, with a bit more detail than here :)

Pascal de Bruijn could you allow your ppa to use a newer version of Lensfun?

lensfun 0.3 series has broke ABI but did not bump the soversion, so it is not safe to just upgrade the lensfun.
similarly, you wouldn't want to upgrade the whole library package from some ppa.

Thank you for your answer.

#3 Updated by Jean-Paul GAUCHE over 1 year ago

Thank you for your answer.

#4 Updated by Jean-Paul GAUCHE over 1 year ago

Thank you for your answer.

Also available in: Atom PDF