Project

General

Profile

Bug #11843

opencl broken with nvidia-384

Added by michael rasmussen over 1 year ago. Updated over 1 year ago.

Status:
Closed: upstream
Priority:
Low
Assignee:
-
Category:
OpenCL
Target version:
Start date:
12/01/2017
Due date:
% Done:

0%

Affected Version:
git stable branch
System:
Debian
bitness:
64-bit
hardware architecture:
amd64/x86

Description

Hi developers,

Yesterday running with nvidia-381 darktable was able to use opencl but today Debian unstable had an Nvidia upgrade to 384 - current stable nvidia version, this is no longer the case since the nvidia cuda api has changed in 384.

$ darktable-cltest
[opencl_init] opencl related configuration options:
[opencl_init]
[opencl_init] opencl: 1
[opencl_init] opencl_library: ''
[opencl_init] opencl_memory_requirement: 768
[opencl_init] opencl_memory_headroom: 350
[opencl_init] opencl_device_priority: '*/!0,*/*/*'
[opencl_init] opencl_size_roundup: 16
[opencl_init] opencl_async_pixelpipe: 0
[opencl_init] opencl_synch_cache: 0
[opencl_init] opencl_number_event_handles: 25
[opencl_init] opencl_micro_nap: 1000
[opencl_init] opencl_use_pinned_memory: 0
[opencl_init] opencl_use_cpu_devices: 0
[opencl_init] opencl_avoid_atomics: 0
[opencl_init] opencl_enable_markesteijn: 1
[opencl_init]
[opencl_init] found opencl runtime library 'libOpenCL'
[opencl_init] opencl library 'libOpenCL' found on your system and loaded
[opencl_init] found 3 platforms
[opencl_init] could not get device id size: -1
[opencl_init] found 2 devices
[opencl_init] device 0 `GeForce GT 1030' has sm_20 support.
[opencl_init] device 0 `GeForce GT 1030' supports image sizes of 16384 x 32768
[opencl_init] device 0 `GeForce GT 1030' allows GPU memory allocations of up to 499MB
[opencl_init] device 0: GeForce GT 1030
GLOBAL_MEM_SIZE: 2000MB
MAX_WORK_GROUP_SIZE: 1024
MAX_WORK_ITEM_DIMENSIONS: 3
MAX_WORK_ITEM_SIZES: [ 1024 1024 64 ]
DRIVER_VERSION: 384.98
DEVICE_VERSION: OpenCL 1.2 CUDA
[opencl_init] could not create context for device 0: 221
[opencl_init] FINALLY: opencl is NOT AVAILABLE on this system.
[opencl_init] initial status of opencl enabled flag is OFF.

History

#1 Updated by michael rasmussen over 1 year ago

I have chosen target version 2.4 but it would be nice if the fix was backported to 2.2.5 since it can take a while before 2.4 appear in a repo near you.

#2 Updated by Roman Lebedev over 1 year ago

1. we dont use cuda
2. pretty sure this is not darktable problem, but closed: upstream

#3 Updated by Ċ½ilvinas Ċ½altiena over 1 year ago

michael rasmussen wrote:

I have chosen target version 2.4 but it would be nice if the fix was backported to 2.2.5 since it can take a while before 2.4 appear in a repo near you.

I am with 387, and previously used 384. DT 2.2.5 and DT 2.4.0RC0 work fine with NVIDIA OpenCL using these driver versions, but I am not on Debian. You probably should look for issues specific to your distro or local installation/config.

#4 Updated by Pascal Obry over 1 year ago

Not a dt issue I would say. Maybe a missing package?

#5 Updated by Roman Lebedev over 1 year ago

  • Status changed from New to Closed: upstream

#6 Updated by Pascal Obry over 1 year ago

Just to show that this is not darktable issue, I get the same error with clinfo:

  clGetPlatformInfo(NULL, CL_PLATFORM_NAME, ...)  NVIDIA CUDA
  clGetDeviceIDs(NULL, CL_DEVICE_TYPE_ALL, ...)   Success [NV]
  clCreateContext(NULL, ...) [default]            <checkNullCtx:2241: create context with device from default platform : error 221>
  clCreateContextFromType(NULL, CL_DEVICE_TYPE_CPU)  No devices found in platform

#7 Updated by michael rasmussen over 1 year ago

Pascal Obry wrote:

Just to show that this is not darktable issue, I get the same error with clinfo:

[...]

Hi all,
Solved the bug which is caused by a missing link:
cd /usr/lib/x86_64-linux-gnu
sudo ln -s nvidia/current/libnvidia-ptxjitcompiler.so.1 .

At lease darktable works again :-)
See bug trace here: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=883303

#8 Updated by Pascal Obry over 1 year ago

Indeed, this works for me too.

I will add this info into https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=883313

And mark it related.

#9 Updated by michael rasmussen over 1 year ago

Pascal Obry wrote:

Indeed, this works for me too.

I will add this info into https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=883313

And mark it related.

New nvidia-driver 384 package which fixes this bug was available as of 2017-12-03 12:00:00.000 CET on a debian repository near you.

Also available in: Atom PDF