Project

General

Profile

Bug #11833

cmake 3.10.0 makes libxml2 not to be found --> compile of dt fails

Added by Axel Gerber 11 months ago. Updated 6 days ago.

Status:
Closed: invalid
Priority:
Low
Assignee:
-
Category:
Buildsystem
Target version:
Start date:
11/26/2017
Due date:
% Done:

0%

Affected Version:
git master branch
System:
other GNU/Linux
bitness:
64-bit
hardware architecture:
amd64/x86

Description

Hi,

as indicated above, on my gentoo system dt-git does not compile after I updated to cmake 3.10.0 (log attached).

On the screen I get
CMake Error at /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:137 (message):
Could NOT find LibXml2 (missing: LIBXML2_LIBRARY) (found suitable version
"2.9.4", minimum required is "2.6")

When I downgrade to cmake 3.9.6 everything is gine

CMakeError.log Magnifier (98.6 KB) Axel Gerber, 11/26/2017 12:54 PM

CMakeOutput.log Magnifier (691 KB) Axel Gerber, 11/26/2017 12:54 PM

History

#1 Updated by Roman Lebedev 11 months ago

  • Status changed from New to Incomplete
  • % Done changed from 0 to 20

Axel Gerber wrote:

Hi,

as indicated above, on my gentoo system dt-git does not compile after I updated to cmake 3.10.0 (log attached).

On the screen I get
CMake Error at /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:137 (message):
Could NOT find LibXml2 (missing: LIBXML2_LIBRARY) (found suitable version
"2.9.4", minimum required is "2.6")

When I downgrade to cmake 3.9.6 everything is gine

I'm not seeing anything about libxml in the attached logs.
You'd need to provide more output, but i strongly suspect that it is cmake's problem.

#2 Updated by Axel Gerber 11 months ago

Dear Roman,

I could imagine, it is finally a cmake issue. I tried again just now and there is no more I could provide. As stated above only on the shell output I get that LibXml2 issue. No more log fies.

Next I will mask cmake 3.10.0 and see, what happens once cmake exceeds that version.

Cheers
Axel

#3 Updated by Christian Kanzian 11 months ago

Same happened here on debian 9, but it was related due to a package ?clash.

I tried to compile GMIC filters and needed libcurl4-openssl-dev, but

libcurl4-gnutls-dev : clashes with libcurl4-openssl-dev

Installing libcurl4-openssl-dev removes libcurl4-gnutls-dev which seems to be required for darktable to compile.
After removing libcurl4-openssl-dev and reinstalling libcurl4-gnutls-dev, darktable configure succeeds.

Maybe it is worth to check, if there is a similar problem on gentoo.

#4 Updated by Roman Lebedev 11 months ago

I'm still not sure why this is darktable's bug.

#5 Updated by Axel Gerber 11 months ago

Dear all,

my gentoo system does not have libcurl at all...

@Roman:
I donno you meant me. Above I said, I can imagine, it is a cmake issue, hence that means not a dt problem...
At the moment I have masked (means prevent from installation) cmake 3.10.0, therefore automatically go back to 3.9.6 For next investigations I gotta wait for cmake >=3.10.1

Anyhow isn't it good, also the dt teams knows, if some libaries go to next level and maybe (provided they are not not not broken) some incompatibilities occur?

#6 Updated by André Reinald 16 days ago

Deleting the old build directory fixed the issue for me.

Hope the trick can help others.

Cheers.

#7 Updated by Roman Lebedev 16 days ago

  • Status changed from Incomplete to Closed: invalid
  • % Done changed from 20 to 0

#8 Updated by Roman Lebedev 6 days ago

  • Target version set to 2.6.0

Also available in: Atom PDF