Project

General

Profile

Bug #11829

Crash on startup of darkdable Windows 10

Added by Gijs van de Ven 2 months ago. Updated 2 days ago.

Status:
Closed: invalid
Priority:
Low
Assignee:
-
Category:
General
Target version:
Start date:
11/21/2017
Due date:
% Done:

0%

Affected Version:
git master branch
System:
Windows
bitness:
64-bit
hardware architecture:
amd64/x86

Description

I just installed darktable-2.3.0+866_gc23bd4a5a-win64 on my 64Bit Windows 10 system.
After completion of the installation procedure I launched DarkTable from the windows start menu.
This crashed.

I have a darktable_bt.txt file with the following content:
-------------------

Error occurred on Tuesday, November 21, 2017 at 15:36:56.

darktable.exe caused an Access Violation at location 0000000063643AC0 in module libdarktable.dll Writing to location 00007FF92A49995C.

AddrPC Params
0000000063643AC0 0000000003D31FE0 0000000000000103 0000000003C083A0 libdarktable.dll!dt_opencl_build_program [C:/darktable/darktable/src/common/opencl.c 1685]
0000000063644F1C 0000000003D31FE0 0000000063870EE0 0000000000000004 libdarktable.dll!dt_opencl_device_init [C:/darktable/darktable/src/common/opencl.c
444]
000000006364B0CA 0000000000000046 00000000637EAB5A 0000000000000000 libdarktable.dll!dt_opencl_init [C:/darktable/darktable/src/common/opencl.c 658]
00000000635E2723 00007FF900000001 00000000013BF9E0 00007FF900000001 libdarktable.dll!dt_init [C:/darktable/darktable/src/common/darktable.c
851]
0000000000402F09 0000000000000000 000000000000002D 0000000000408988 darktable.exe!main [C:/darktable/darktable/src/main.c 64]
00000000004013F7 0000000000000000 0000000000000000 0000000000000000 darktable.exe!__tmainCRTStartup [D:/develop/scripts/mingw-w64-crt-git/src/mingw-w64/mingw-w64-crt/crt/crtexe.c
334]
00000000004014FB 0000000000000000 0000000000000000 0000000000000000 darktable.exe!WinMainCRTStartup [D:/develop/scripts/mingw-w64-crt-git/src/mingw-w64/mingw-w64-crt/crt/crtexe.c @ 184]
00007FF92A7A2774 0000000000000000 0000000000000000 0000000000000000 KERNEL32.DLL!BaseThreadInitThunk
00007FF92CCE0D51 0000000000000000 0000000000000000 0000000000000000 ntdll.dll!RtlUserThreadStart

darktable.exe 2.3.0.0
ntdll.dll 10.0.15063.447
aswhooka.dll 17.7.3.15075
KERNEL32.DLL 10.0.15063.296
KERNELBASE.dll 10.0.15063.483
msvcrt.dll 7.0.15063.0
libglib-2.0-0.dll 2.52.3.0
ADVAPI32.dll 10.0.15063.0
sechost.dll 10.0.15063.0
RPCRT4.dll 10.0.15063.0
ole32.dll 10.0.15063.483
combase.dll 10.0.15063.296
ucrtbase.dll 10.0.15063.413
bcryptPrimitives.dll 10.0.15063.0
GDI32.dll 10.0.15063.0
gdi32full.dll 10.0.15063.413
msvcp_win.dll 10.0.15063.0
USER32.dll 10.0.15063.0
win32u.dll 10.0.15063.0
SHELL32.dll 10.0.15063.483
cfgmgr32.dll 10.0.15063.0
shcore.dll 10.0.15063.0
windows.storage.dll 10.0.15063.483
shlwapi.dll 10.0.15063.0
kernel.appcore.dll 10.0.15063.0
powrprof.dll 10.0.15063.0
profapi.dll 10.0.15063.0
WS2_32.dll 10.0.15063.0
libintl-8.dll 0.19.8.0
libdarktable.dll
PSAPI.DLL 10.0.15063.0
libwinpthread-1.dll 1.0.0.0
WINMM.dll 10.0.15063.0
libpcre-1.dll
libiconv-2.dll 1.15.0.0
libgcc_s_seh-1.dll
libstdc++-6.dll
libcairo-2.dll
exchndl.dll 0.8.1.0
libexiv2.dll
libgdk-3-0.dll 3.22.18.0
IMM32.dll 10.0.15063.0
SETUPAPI.dll 10.0.15063.0
libgdk_pixbuf-2.0-0.dll 2.36.8.0
libgio-2.0-0.dll 2.52.3.0
libgmodule-2.0-0.dll 2.52.3.0
libgobject-2.0-0.dll 2.52.3.0
libgphoto2-6.dll
libgphoto2_port-12.dll
libGraphicsMagick-3.dll
libIlmImf-2_2.dll
libjpeg-8.dll
libjson-glib-1.0-0.dll
liblcms2-2.dll
lua53.dll
libpango-1.0-0.dll 1.40.10.0
libpangocairo-1.0-0.dll 1.40.10.0
libpng16-16.dll
libsecret-1-0.dll
libsoup-2.4-1.dll
libsqlite3-0.dll
libtiff-5.dll
zlib1.dll
libpugixml.dll
WINMMBASE.dll 10.0.15063.0
MSIMG32.dll 10.0.15063.0
libfontconfig-1.dll
libfreetype-6.dll
mgwhelp.dll 0.8.1.0
VERSION.dll 10.0.15063.0
libexpat-1.dll
dwmapi.dll 10.0.15063.0
libcairo-gobject-2.dll
gdiplus.dll 10.0.15063.483
DNSAPI.dll 10.0.15063.0
NSI.dll 10.0.15063.0
IPHLPAPI.DLL 10.0.15063.0
libffi-6.dll
libexif-12.dll
libltdl-7.dll
libsystre-0.dll
libbz2-1.dll
libHalf-2_2.dll
libIex-2_2.dll
libIlmThread-2_2.dll
libImath-2_2.dll
libpangoft2-1.0-0.dll 1.40.10.0
liblzma-5.dll 5.2.3.0
dbghelp.dll 10.0.15063.250
libtre-5.dll
dbgcore.DLL 10.0.15063.0
libgomp-1.dll
libgtk-3-0.dll 3.22.18.0
comdlg32.dll 10.0.15063.332
libopenjp2-7.dll
libxml2-2.dll
libpixman-1-0.dll
libepoxy-0.dll
libpangowin32-1.0-0.dll 1.40.10.0
libgcrypt-20.dll 1.8.0.30296
libharfbuzz-0.dll
COMCTL32.dll 6.10.15063.483
WINSPOOL.DRV 10.0.15063.483
libatk-1.0-0.dll 2.24.0.0
USP10.dll 10.0.15063.0
libgraphite2.dll
bcrypt.dll 10.0.15063.0
libgpg-error-0.dll 1.27.0.0
CRYPTSP.dll 10.0.15063.0
rsaenh.dll 10.0.15063.0
CRYPTBASE.dll 10.0.15063.0
uxtheme.dll 10.0.15063.0
OLEAUT32.dll 10.0.15063.332
clbcatq.dll 2001.12.10941.16384
propsys.dll 7.0.15063.0
MSCTF.dll 10.0.15063.332
DEVOBJ.dll 10.0.15063.0
WINTRUST.dll 10.0.15063.0
MSASN1.dll 10.0.15063.0
CRYPT32.dll 10.0.15063.296
OpenCL.dll 2.1.0.0
amdocl64.dll 10.0.1800.11
OPENGL32.dll 10.0.15063.0
GLU32.dll 10.0.15063.0
atiadlxx.DLL 7.15.20.1301
USERENV.dll 10.0.15063.0
WTSAPI32.dll 10.0.15063.0
amdocl12cl64.dll 0.8.0.0
atig6txx.dll 8.14.1.6463
atiumd6a.dll 8.14.10.513
IntelOpenCL64.dll 21.20.16.4551
intelocl64.dll 6.8.0.396
task_executor64.dll 6.8.0.396
cpu_device64.dll 6.8.0.396
igdrcl64.dll 21.20.16.4551
dxgi.dll 10.0.15063.0
igdfcl64.dll 21.20.16.4551
igdmcl64.dll 21.20.16.4551
igc64.dll 21.20.16.4551
TextInputFramework.dll 10.0.15063.0
CoreUIComponents.dll 10.0.15063.483
CoreMessaging.dll 10.0.15063.483
ntmarta.dll 10.0.15063.0
wintypes.dll 10.0.15063.0
usermgrcli.dll 10.0.15063.0

Windows 10.0.15063
DrMingw 0.8.1
------------------------------------------------------------------------

I hope this infomation is helpful for you to locate the cause of the problem.

Thank you for porting this great software to Windows.

History

#1 Updated by Roman Lebedev 2 months ago

  • Subject changed from Crash on startup of DarkTable Windows 10 to Crash on startup of darkdable Windows 10

DarkTable

Never ever say that again.

#2 Updated by Roman Lebedev 2 months ago

  • Affected Version changed from 2.2.5 to git master branch

Also, certainly not 2.2.5

#3 Updated by Tobias Ellinghaus about 2 months ago

IIRC that was fixed already, please give 2.3.0+1049 a try (https://discuss.pixls.us/t/darktable-for-windows/4966/193).

#4 Updated by Peter Budai about 1 month ago

Can we close this case?

#5 Updated by Peter Budai 15 days ago

We can close this case due to lack of response

#6 Updated by Roman Lebedev 15 days ago

  • Status changed from New to Closed: invalid

#7 Updated by Roman Lebedev 2 days ago

  • Target version set to 2.6.0

Also available in: Atom PDF